BookmarkSubscribeRSS Feed
kgeorge130
Fluorite | Level 6

Having an issue with a new install of SAS Viya 3.4,  If Install with out configuring HTPD with my server certificates I am able to go through the post-install and login as sasboot. As soon as I add my certificates either post install or pre install I am unable to login.  I have verified that the ssl certs are valid, if I set them up on apache before I try to install Viya the test page comes up as secure. 

 

With the ssl certs in place when you try to login I am getting the following errors. from Firefox, 

 

{
  "errorCode": 401,
  "message": "Authentication Failed: Could not obtain access token",
  "details": [
    "path: /SASDrive/"
  ],
  "links": [],
  "version": 2,
  "httpStatusCode": 401
}

 

If I try and open it from IE before the page even loads I am getting this (see the attachment),  like it is trying to download a file. 

 

I have tried to run the playbook

renew-security-artifacts  as well as distribute-httpd-certs with no change in the situation.

 

here is also a snip from the saslogon-default logs

 

2019-08-05 11:25:53.943  INFO 8958 --- [n Asynchronous5] c.s.c.bootstrap.ConfigurationLoader      : service [3e83fcacae6aa99d] [CONFIGURATION_BOOTSTRAP_OBTAINED_ACCESS_TOKEN] An access token has been obtained.
2019-08-05 11:25:53.959 ERROR 8958 --- [n Asynchronous5] c.s.c.bootstrap.ConfigurationLoader      : service [3e83fcacae6aa99d] [CONFIGURATION_BOOTSTRAP_RESTCLIENT_EXCEPTION] com.sas.configuration.bootstrap.ConfigurationLoader@3cbfdf5c encountered an exception attempting to invoke the [HTTPMethod=POST][endPoint=/configuration/definitions]

 

if anyone has any suggestions where to look next I would appreciate it? 

 

thanks

Kevin

 

 

5 REPLIES 5
alexal
SAS Employee

@kgeorge130 ,

 

I'm wondering, why you didn't specify your SSL certificates during the deployment process as described here?

kgeorge130
Fluorite | Level 6

Actually that was they way I did it the first time and still had the same issues, tried it the other way just to troubleshoot.

alexal
SAS Employee

@kgeorge130 ,

 

Did you get the same error about CONFIGURATION_BOOTSTRAP_RESTCLIENT_EXCEPTION when the certificates were specified in vars.yml before the deployment?

kgeorge130
Fluorite | Level 6

I believe so,  I should have saved the log file from then to compare. 

kgeorge130
Fluorite | Level 6
Any ideas on what might be causing that problem?

suga badge.PNGThe SAS Users Group for Administrators (SUGA) is open to all SAS administrators and architects who install, update, manage or maintain a SAS deployment. 

Join SUGA 

Get Started with SAS Information Catalog in SAS Viya

SAS technical trainer Erin Winters shows you how to explore assets, create new data discovery agents, schedule data discovery agents, and much more.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 5 replies
  • 2698 views
  • 0 likes
  • 2 in conversation