BookmarkSubscribeRSS Feed
🔒 This topic is solved and locked. Need further help from the community? Please sign in and ask a new question.
Cherry
Obsidian | Level 7

Hi,

Few SAS Viya users getting below error while they are trying to login to SAS Viya home page ( SAS Drive), cleared cache and tried to login on other machine with same userid and password but still no luck. Currently all users are working from home via VPN, they are able to work with other applications without any issues.

SAS Viya 3.5 hosted on RHEL(Azure VM)

Can you please advise.

 

Cherry_0-1591797153391.png

 

Thanks,

Cherry.

1 ACCEPTED SOLUTION

Accepted Solutions
jcFranklin
SAS Employee

Hello Cherry,

 

It does look like an LDAP/AD issue. From searching google on the error message it looks like a CNF attribute in the DN might be causing the issue:

 

https://confluence.atlassian.com/crowdkb/syncing-with-ldap-directories-containing-cnf-attributes-pro...

 

https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-2000-server/bb727059(v=tec...

View solution in original post

4 REPLIES 4
Anand_V
Ammonite | Level 13
What do you see in the log?
jcFranklin
SAS Employee

Hello Cherry,

 

I would start by checking the SASLogon and Drive logs. They will be located in /opt/sas/viya/config/var/log/SASLogon/defaultsas-saslogon*.log & /opt/sas/viya/config/var/log/Drive/default/sas-drive*.log. 

 

Check that your services are up and running: 

sudo /etc/init.d/sas-viya-all-services status

 

If all users are unable to access Viya, I would recommend opening a SAS Technical Support track for help as well: https://support.sas.com/en/technical-support/contact-sas.html

 

-Jessica

Cherry
Obsidian | Level 7

Hi Franklin,

All services are up and running, as I told that only very few users got this issue and rest are working without issue.

I raised a incident with SAS Tech Support and I have sent all required logs to them for their analysis. They are saying that I need to check with LADP or AD admin on this.

Error Message on Logs as below( I have masked few fields for security):

Cherry_0-1591800868272.png

 

Please advise.

 

Thanks,

Cherry.

jcFranklin
SAS Employee

Hello Cherry,

 

It does look like an LDAP/AD issue. From searching google on the error message it looks like a CNF attribute in the DN might be causing the issue:

 

https://confluence.atlassian.com/crowdkb/syncing-with-ldap-directories-containing-cnf-attributes-pro...

 

https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-2000-server/bb727059(v=tec...

suga badge.PNGThe SAS Users Group for Administrators (SUGA) is open to all SAS administrators and architects who install, update, manage or maintain a SAS deployment. 

Join SUGA 

CLI in SAS Viya

Learn how to install the SAS Viya CLI and a few commands you may find useful in this video by SAS’ Darrell Barton.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 4 replies
  • 1458 views
  • 1 like
  • 3 in conversation