BookmarkSubscribeRSS Feed
jwward65
Obsidian | Level 7

Is there a way to disable the "Schedule as Job" option in SAS Studio V?

 

jwward65_0-1610572090444.png

 

 

Due to volume, we need all scheduling to come through a central processing request to be appropriately scheduled by administrators.

 

Thanks!
John

7 REPLIES 7
Anand_V
Ammonite | Level 13

Hi @jwward65 

 

I am not sure but I think there isn't any OOTB option to restrict this option. However in Viya you can use rules to explicitly deny access to certain URI's. You can find more about this in the reference links provided below. In the URI reference link you can find different URIs related to Job Management.

 

Job Management2

Schedule jobs.

/jobExecution/jobRequests/*

/jobExecution/jobRequests/*/

Both URIs are required (two separate rules).

Edit scheduled jobs.

/scheduler/jobs/**

 

Monitor jobs.

/jobExecution/jobs/**

 

Reference:

Access to Functionality: Overview 

Example Instructions on how to restrict functionality access using URIs 

Access to Functionality: URI Reference 

jwward65
Obsidian | Level 7

I actually already disabled the two rules for "Schedule jobs", but the option is still there in SAS Studio V.  So, either I don't have the correct rule or there is a bug in SAS Studio V.

jwward65
Obsidian | Level 7

Okay, in testing, it appears that even the option is still available, a job is not actually scheduled.  This can be very deceiving to end users who think they are scheduling a job, but reviewing the "Scheduled jobs" view in SAS Studio V and or EVM Jobs and Flows, no scheduled job is displayed.

 

I'll submit a SAS Support Track to report the bug that the "Schedule as a job" isn't greyed out when the rule is disabled.

JessLund
Obsidian | Level 7

Hi I had a similar dilemma at my site. 

 

Did SAS Tech support help resolve the issue? 

 

As far as I know its not possible to prevent job scheduling in SAS Studio. 

EyalGonen
Lapis Lazuli | Level 10

 Hi @jwward65 

 

Did you get an answer from Tech Support? If so, can you tell me what they said?

 

Thanks

jwward65
Obsidian | Level 7

Support told me that the option can be disabled via the Rules, but it still shows as an option in the Menu.  The kicker is that it appears to the end user that the job was actually scheduled, but didn't actually if the option is disabled.  No message or error to the end user.  I asked support about this and they said 'this is by design' which makes no sense to me!

EyalGonen
Lapis Lazuli | Level 10

I agree, this makes no sense. Also, if you disable the rules I think it not only blocks SAS Studio but also all other SAS web apps from being able to Schedule a Job. I would expect to have an option within SAS Studio itself to disable this functionality... I will open another track with Tech Support to see if anything has changed since you asked them. I will update 🙂

suga badge.PNGThe SAS Users Group for Administrators (SUGA) is open to all SAS administrators and architects who install, update, manage or maintain a SAS deployment. 

Join SUGA 

CLI in SAS Viya

Learn how to install the SAS Viya CLI and a few commands you may find useful in this video by SAS’ Darrell Barton.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 7 replies
  • 933 views
  • 4 likes
  • 4 in conversation