BookmarkSubscribeRSS Feed
Frank_Boekamp
Quartz | Level 8

I get an error saving a report with a list table with word wrap property set to yes.

 

Is this a bug and can this be fixed quickly please?

6 REPLIES 6
Madelyn_SAS
SAS Super FREQ

What is the error? Can you consistently reproduce it with any report?

Frank_Boekamp
Quartz | Level 8

I tried different datasets and they all give the same result when checking 'word wrap'  in a listtable and saving the report:

 

'An error was encountered saving the report'

 

I enclosed print-screens of an example with a good oldie dataset (sashelp.class)

 

 

sit_1.jpgsit_2.jpg

Madelyn_SAS
SAS Super FREQ

I cannot reproduce the error, and I don't see any other reports of a problem with text wrap. I am using 8.3.1 on Linux. What is your exact release from the About dialog box. If you go into Environment Manager, are any errors being logged.

Frank_Boekamp
Quartz | Level 8

Hi Madelyn,

 

I looked more into this issue: it's not just a problem with the 'text wrap' property but it seems to have this effect on certain other properties in the Listtable as well, like properties from the Style group and from Cells and Table group. And the issue also manifests in other objects like in a bar chart with certain properties. I can not open a part of the reports anymore because of this issue.

 

The behavior is very consistent, some properties never give a problem, others always give a problem. I tried different browsers with same results.

 

The about dialog box you mention I can not find, can you give me a hint where I can find this?

Maybe following helps you: these are the first two XML lines (from the BIRD editor) of a SAS VA report:

<?xml version="1.0" encoding="UTF-8"?>
<SASReport xmlns="http://www.sas.com/sasreportmodel/bird-4.1.2" label="mytest4" createdLocale="en" createdVersion="4.1.2" dateCreated="2019-02-21T17:17:18Z" dateModified="2019-02-21T18:17:06Z" createdApplication="SAS Visual Analytics 8.3.1" lastModifiedApplication="SAS Visual Analytics 8.3.1" nextUniqueNameIndex="102">

 

From the Environment Manager I see no log messages at all, so no errors there.

 

Maybe following will help you: the XML code (from the BIRD editor) of a SAS VA report with an issue after I tried to save it:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?><error errorCode="0" httpStatusCode="500"><details><detail>correlator: 1027d51d-6812-40f3-aa0f-6c67778d85da</detail><detail>traceId: d6484a4db7a82fba</detail><detail>path: /reports/content</detail></details><links/><version>2</version></error>

 

Cheers,

Frank

 

 

 

 

 

 

 

 

Frank_Boekamp
Quartz | Level 8

The problem is solved by our hosting provider. Thanks for your support

Madelyn_SAS
SAS Super FREQ

I could not reproduce this issue, but I would be interested in the solution. Do you know what they did to fix it?

sas-innovate-2024.png

 

Secure your spot at the must-attend AI and analytics event of 2024: SAS Innovate 2024! Get ready for a jam-packed agenda featuring workshops, super demos, breakout sessions, roundtables, inspiring keynotes and incredible networking events.

 

Register by March 1 to snag the Early Bird rate of just $695! Don't miss out on this exclusive offer. 

 

Register now!

Tips for filtering data sources in SAS Visual Analytics

See how to use one filter for multiple data sources by mapping your data from SAS’ Alexandria McCall.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 6 replies
  • 894 views
  • 0 likes
  • 2 in conversation