BookmarkSubscribeRSS Feed
piyushas
Fluorite | Level 6

Hi,

 I've been using SAS for about 6 months without any issues.  Today I tried to launch SAS and was asked to update the virtualbox software and now SAS can't find shared folders.  I've tried everything includeing doing a full install from scratch but still keep getting this message:

 

A shared folder named "myfolders" was not found on the virtual machine. See the FAQ for details.

 

Things I have tried:

- Doing a full install with updated VirtualBox and SAS

- Using different browsers

- Changing the location of the shared folders from a network drive to the C drive.

 

TIA

 

 

I'm assuming I can still run SAS it just won't save any of my work.... All help is appreciated (b/c of course I'm on a dealine!)

 

Piyusha

18 REPLIES 18
Reeza
Super User

Restart your VM. 

 

Check the shared folder setting in the VM - post a snapshot and when setting it up make sure to check the box that says its connected automatically everytime you restart.


Navigate to the Servers Files Folders Pane

Find the myfolders folder

Right click it, select Properties

Copy the path

 

Then do:

 

libname test '/folders/myfolders/';

If it doesn't work post the log and the screenshots of your VM setting and properties in SAS UE.

 

 

mcg
Calcite | Level 5 mcg
Calcite | Level 5

I had the same problem this AM.   Tried the remap of the drive and everything else I could think of.

I rolled my VirtualBox install back to 5.2.6 and the problem went away. 

Not sure why, but the VirtualBox upgrade to 5.2.8 created the problem with the shared drive for me.

Mike 

piyushas
Fluorite | Level 6

about to try this.

piyushas
Fluorite | Level 6

Where did you find 5.2.6? 

piyushas
Fluorite | Level 6

image.png   

 

Path for myfolders in Server Files Pane

 

image.png

 

 

OPTIONS NONOTES NOSTIMER NOSOURCE NOSYNTAXCHECK;
72
73 libname test '/folders/myfolders';
NOTE: Libref TEST was successfully assigned as follows:
Engine: V9
Physical Name: /folders/myfolders
74 run;
75
76 OPTIONS NONOTES NOSTIMER NOSOURCE NOSYNTAXCHECK;
89

 

It works but the Folder Shortcuts do not find my existing SAS files and input data that were in myfolders

mcg
Calcite | Level 5 mcg
Calcite | Level 5
The VirtualBox guest has a /folders/myfolders, so the libname will work.
But the guest machine's folder is not connected to the associated host
machines folder, so there is none of the host content in that location.
Mike
piyushas
Fluorite | Level 6

Thanks!

Does it still save my files between sessions?

Reeza
Super User

Is the folder/path the same one you used before?

 

If not, either set it there or move the files into the new myfolders location.

piyushas
Fluorite | Level 6

@Reeza wrote:

Is the folder/path the same one you used before?

 

 

If not, either set it there or move the files into the new myfolders location.


 

 

For my shared folders?  Yes.  

But I moved it to my c drive from my i: incase the network drive was the issue.  Didnt' work then either.

 

>>If not, either set it there or move the files into the new myfolders location.

not sure I understand...?

piyushas
Fluorite | Level 6

Went back to VirtualBox 5.2.4

still get the message about not being able to find folders, but if I go ahead and launch SAS, I do see my files in the shared location.

 

Am going to go ahead and work with this now and will try and figure out whey 5.2.8 is not working for me after I meet my deadline.

Are you on 5.2.8 and not having issues?

mcg
Calcite | Level 5 mcg
Calcite | Level 5
you may need to manually set the myfolders shared file back on in the 5.2.6
'settings', but that myfolders on your host should have a .sasstudio,
.images, .uestart and .fontconfig to preserve all your prior settings and
preferences.

I'm on 5.2.6 and will check back in a month.
5.2.4 will work fine too.

I think you folder error message will disappear if you refresh your
session... that error message went away for me.

Mike

piyushas
Fluorite | Level 6

Ugh.

It's still not working... It can't find my data:

 

image.png

mcg
Calcite | Level 5 mcg
Calcite | Level 5

suggest you shutdown your virtual guest on 5.2.4 and then make sure to go to the Setting --> Shared Folders and verify the mapping....

Then startup your guest again and open a new SAS Studio session?

Hope this helps.

Mike

RandyMullis
Rhodochrosite | Level 12

Hi, @piyushas and @mcg and @Reeza. I can verify that there's a problem with VirtualBox 5.2.8 and Shared Folders. Reverting back to 5.2.4 does appear to fix the issue. Hoping that Oracle will rush out a fix for this soon!

 

Here's the page for downloading version 5.2.4:

https://www.virtualbox.org/wiki/Download_Old_Builds_5_2 

 

Regards,

Randy

 

Ready to join fellow brilliant minds for the SAS Hackathon?

Build your skills. Make connections. Enjoy creative freedom. Maybe change the world. Registration is now open through August 30th. Visit the SAS Hackathon homepage.

Register today!
How to Concatenate Values

Learn how use the CAT functions in SAS to join values from multiple variables into a single value.

Find more tutorials on the SAS Users YouTube channel.

Click image to register for webinarClick image to register for webinar

Classroom Training Available!

Select SAS Training centers are offering in-person courses. View upcoming courses for:

View all other training opportunities.

Discussion stats
  • 18 replies
  • 3562 views
  • 2 likes
  • 6 in conversation