BookmarkSubscribeRSS Feed
🔒 This topic is solved and locked. Need further help from the community? Please sign in and ask a new question.
titan31
Quartz | Level 8

Hi,

 

I'm trying to run a DataFlux batch job  (deployed to Data Management Server) through Data Integration Studio so that we can schedule it.

 

I'm able to select server and the job but when I run it, it fails. Best I can see logging wise is in the dmserver.log, I'm getting 

 

0106_14:07:47.779 INFO rid:4587; failed to authenticate 'srv-sas'; error: Failed to authenticate user 'srv-sas' (ERROR: Access denied. ).

 

We don't have DataFlux Authentication Server, so it's authenticating via MetaData Server. If I go to DataFlux itself, I can run the job under that srv-sas user so not sure where I'm going wrong. 

 

Main aim is just to schedule the dataflux job, so I've been trying via cron too but getting an ODC error on that. 

 

Thanks for any help

1 ACCEPTED SOLUTION

Accepted Solutions
titan31
Quartz | Level 8

Hi,


So just incase anyone else gets this issue in the future. The issue was that in DI I had Use runtime lookup for credentials for statements requiring credentials turned on.

 

When I switched that off (under tools/option), it works, and i was able to redeploy it and it's running fine on the scheduler. 

View solution in original post

8 REPLIES 8
Rama_V
Obsidian | Level 7

What is the version of DataFlux Server? It may be possible the configuration file which might have authorization information to DataFlux server jobs.

titan31
Quartz | Level 8
It's product version is 2.7 and server version is 9.7
titan31
Quartz | Level 8

Hi, was actually following that document before posting here. Where I'm stuck is for the DQOptions part, do you know where that goes, as it says in the reference, place it into SASV9.CFG, but which SASV9.CFG it doesn't specify.

I have the below ones for example


./sashome/SASFoundation/9.4/sasv9.cfg
./sasconf/Lev1/SASApp/BatchServer/sasv9.cfg
./sasconf/Lev1/SASApp/StoredProcessServer/sasv9.cfg
./sasconf/Lev1/SASApp/WorkspaceServer/sasv9.cfg
./sasconf/Lev1/SASApp/ConnectServer/sasv9.cfg
./sasconf/Lev1/SASApp/sasv9.cfg
./sasconf/Lev1/SchedulingServer/sasv9.cfg

Would it be all of them you specify it in, or just the main SASApp one, or somewhere else?

Kurt_Bremser
Super User

Put the additions here:

./sasconf/Lev1/SASApp/sasv9_usermods.cfg

Don't make changes to the sasv9.cfg files, as these are overwritten when software updates are done.

titan31
Quartz | Level 8
Hi,

I reckon I got the syntax wrong, but I added below in to that file and it didn't work,
dqoptions=(DQSRVPROTOCOL=SOAP)

Would you know the correct syntax?

Thanks
titan31
Quartz | Level 8

Hi,


So just incase anyone else gets this issue in the future. The issue was that in DI I had Use runtime lookup for credentials for statements requiring credentials turned on.

 

When I switched that off (under tools/option), it works, and i was able to redeploy it and it's running fine on the scheduler. 

sas-innovate-2024.png

Don't miss out on SAS Innovate - Register now for the FREE Livestream!

Can't make it to Vegas? No problem! Watch our general sessions LIVE or on-demand starting April 17th. Hear from SAS execs, best-selling author Adam Grant, Hot Ones host Sean Evans, top tech journalist Kara Swisher, AI expert Cassie Kozyrkov, and the mind-blowing dance crew iLuminate! Plus, get access to over 20 breakout sessions.

 

Register now!

How to connect to databases in SAS Viya

Need to connect to databases in SAS Viya? SAS’ David Ghan shows you two methods – via SAS/ACCESS LIBNAME and SAS Data Connector SASLIBS – in this video.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 8 replies
  • 1422 views
  • 1 like
  • 3 in conversation