BookmarkSubscribeRSS Feed
🔒 This topic is solved and locked. Need further help from the community? Please sign in and ask a new question.
ChandanKSAS
Obsidian | Level 7

HI,

 

I am facing an issue, when i'm connecting SASApp Server through SAS EG, it is taking more than 10 minutes to connect. And when validating SAS Workspace server in SMC it is also taking more than 10 minutes to validate. I checked the workspace server log and found IOM ENTRY ServerProxy {compRef:7f83143ef840}->CompDtor() this step taking more than 3 minutes with multiple (4) entry.

Not able to recognize the issue.

 

Any help will be greatly appreciated.

 

Thank you!!

1 ACCEPTED SOLUTION

Accepted Solutions
ChandanKSAS
Obsidian | Level 7

Resolved, Some pre-assigned library was causing the problem.

View solution in original post

6 REPLIES 6
ankitd
Obsidian | Level 7

Have you recently performed any configuration changes post which this is occurring or is this a new installation and the issue has begun?

 

Assuming that host entries have been setup properly or globally defined correctly. If not worth doing that first.

 

Further, is this limited to just workspace validation or is it related to other IOM Servers i.e. PWS and SP as well?

If this is a Linux deployment, can you try launching SMC via the Linux terminal using X Windows and check the validation.

If this is a windows deployment, try launching  SMC via the windows machine where Metadata/Compute servers have been deployed and validate workspace server.

 

This will help you understand if there is a proxy issue or something at the network level which could be causing this.

ChandanKSAS
Obsidian | Level 7

@ankitd  this is the old installation in Linux and we didn't do any changes recently, it was working fine just 10 days ago.

This is the test env and it is working normal in prod env.

I also restarted the Objectspawner but still same problem is there.

I validated all the servers under SASApp and problem is only with Workspace server.

Due to some client limitation i can't use X windows here.

ankitd
Obsidian | Level 7

@ChandanKSAS I suppose there has been some accidental changes either in Workspace server configuration via SMC (check this link for IOM bridges -- https://support.sas.com/rnd/itech/doc9/admin_oma/sasserver/iombridge/index.html) you can try to compare it with your production environment for similarity purpose.

 

The test via X-windows is important to validate to rule out any firewall/network level issues against the port using Workspace server.

While this is just a test and would not be as good as the X-windows, worth checking via the telnet command against the port to ensure there is no lag.

 

Additionally you can:

Ask tracing to be performed by your OS and Network team while you try to validate the Workspace.

Enable detailed logging on the workspace server and see what is getting captured.

These would help get more clarity.

ChandanKSAS
Obsidian | Level 7

Resolved, Some pre-assigned library was causing the problem.

SASKiwi
PROC Star

If these are libraries connect to external databases then using the DEFER = YES option can improve assignment times.

SASKiwi
PROC Star

@ChandanKSAS  - It wouldn't do any harm to simply reboot your whole SAS test environment to see if this clears the problem. It may save you a lot of time troubleshooting.

suga badge.PNGThe SAS Users Group for Administrators (SUGA) is open to all SAS administrators and architects who install, update, manage or maintain a SAS deployment. 

Join SUGA 

CLI in SAS Viya

Learn how to install the SAS Viya CLI and a few commands you may find useful in this video by SAS’ Darrell Barton.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 6 replies
  • 1670 views
  • 0 likes
  • 3 in conversation