BookmarkSubscribeRSS Feed
Barite | Level 11

Hi folks,


We have a user that, from one day to another, when tried to open a Data on SAS AddIn in Excel shows only SAS Folder. The Server to select libname, that not appears. She also use SAS EG and everything works fine on SAS EG.


Screen Shot 2020-09-14 at 23.15.26.jpg



Ammonite | Level 13

Hi @MariaD 


Is this scenario only for a single user or all users? If it is for a single user, can you compare the permissions in SMC for this user with others?

Amethyst | Level 16

Hello @MariaD ,


I would suspect there is a problem in Firewall and/or registration of the COM components. Indeed, I would check if this issue happens only for this user, or more. Is this a virtualized client (Citrix/AppV...) or is it a local installation?


I would definitely try to enable the logging for this client, restart the client and try again the operation, to check the log afterwards:

Barite | Level 11

For now, happens only for one user. Until last week, the user has not problem.



Amethyst | Level 16

I can imagine well that something changed from the infra side. The answers to the questions above would help to filter and surround the issue.

Pyrite | Level 9

I would do two things:


1) Go to %APPDATA%\SAS and rename the SAS-Folder. Then try again.

2) Go to Excel --> Options --> AddIns --> COM AddIns and delete the SAS AddIn. Then go to the Installationdirectory of your Add-In and execute the SwitcherUtility.exe to reinstall the COM-Addin. Then try again.

suga badge.PNGThe SAS Users Group for Administrators (SUGA) is open to all SAS administrators and architects who install, update, manage or maintain a SAS deployment. 

Join SUGA 

CLI in SAS Viya

Learn how to install the SAS Viya CLI and a few commands you may find useful in this video by SAS’ Darrell Barton.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 5 replies
  • 4 in conversation