BookmarkSubscribeRSS Feed
japsas100
Pyrite | Level 9

Hello,

 

We are getting below error with proc http . Please advise?

Please see below the log. I can access the login ID and password page with below URL.

 

25 GOPTIONS ACCESSIBLE;
26 filename _tmpfref
26 ! "/usr/opt/SAS/SASData/SASData/IEM/Global_SearchIndex_UpdateData/Source/search_config_files/rr_search_config.xml";
27 proc http
27 ! url="https://ecrr1.xx.xx.com:8343/SASWIPClientAccess/rest/content/545100/SearchConfig/attachments/279/con..."
27 ! method="get"
28 out=_tmpfref ct="application/x-www-form-urlencoded" HTTP_TOKENAUTH ;
29
30
31 GOPTIONS NOACCESSIBLE;
32 %LET _CLIENTTASKLABEL=;
33 %LET _CLIENTPROCESSFLOWNAME=;
34 %LET _CLIENTPROJECTPATH=;
35 %LET _CLIENTPROJECTPATHHOST=;
36 %LET _CLIENTPROJECTNAME=;
37 %LET _SASPROGRAMFILE=;
38 %LET _SASPROGRAMFILEHOST=;
39
40 ;*';*";*/;quit;

ERROR: Unauthorized: Check username/password.
NOTE: The SAS System stopped processing this step because of errors.
NOTE: PROCEDURE HTTP used (Total process time):
real time 0.59 seconds
cpu time 0.02 seconds

8 REPLIES 8
gwootton
SAS Super FREQ
When you access the URL via browser and enter your credentials, does it then produce the desired results?

The ERROR message suggests the credentials being used to connect to Metadata to get the token (HTTP_TOKENAUTH) may not have permission to access that URL. Does adding an options statement above the PROC HTTP to use the SAS Administrator account result in different behavior? For example:

options metaserver="meta.demo.sas.com" metaport=8561 metauser="sasadm@saspw" metapass="password";
--
Greg Wootton | Principal Systems Technical Support Engineer
japsas100
Pyrite | Level 9

@gwootton 

 

I have recently changed the sasadm@sapw password in Mid, COmpute and metadata sever with SDM. Also manually changed the encoded password for all the config files .

 

 

Seems like this is password related issue. We are using SAS 9.4 M1. Please advise?

japsas100
Pyrite | Level 9

@gwootton 

 

I am still getting the same error with below sasadm@saspw credentials.

options metaserver="meta.demo.sas.com" metaport=8561 metauser="sasadm@saspw" metapass="password";

gwootton
SAS Super FREQ
Did you update them with the appropriate metadata server and metadata password for your environment?

Does your code not have a "run;" after the proc http line?
--
Greg Wootton | Principal Systems Technical Support Engineer
AMSAS
SAS Super FREQ

The error message indicates it's a user/password issue, but you appear to have tested that based on " I can access the login ID and password page with below URL."

I recommend you open a TS track for this question.

Please include the following:
- SAS Version you are running (the following code will report SAS version information)
%put &sysvlong ;
%put &sysscpl ;
%put &syssite ;
- Registry Report (*.txt files) for each server, please clearly name the report files to reflect the server it was executed on.
- The code

- The full log
- Has this been working in the past, if so when was it last working, and what has changed?

 

japsas100
Pyrite | Level 9

I have already open the track with SAS but no luck so far.

 

As I mentioned we have recently changed the sas internal account password (min 25 character long). And password also included special character -*$@.

 

Please advise?

Kurt_Bremser
Super User

With 25 characters, you do not need any special characters. Upper/lowercase letters, digits and underlines allow 63**25 permutations. A randomly generated password with these characters can't be brute-forced.

Sajid01
Meteorite | Level 14

Hello @japsas100 
1.If you are able to login as sasadm@saspw into the server using SMC then you are good with the password and you must focus on proc http.

2.From your post it is clear it is an authentication failure.  Did it work before the passwords were updated?

You can try other methods of authentication too.

Similarly try experimenting using other tools such as curl / postman /ARC client ot Jmeter. 

3. One more suggestion You are using and xml file in creating fileref. In that event then try specifying content-type (ct) as  'text/xml'. using verbose option will also help.

4.Please do verify file and folder permissions.

5.If nothing else works, I suggest changing the passwords.

 

suga badge.PNGThe SAS Users Group for Administrators (SUGA) is open to all SAS administrators and architects who install, update, manage or maintain a SAS deployment. 

Join SUGA 

CLI in SAS Viya

Learn how to install the SAS Viya CLI and a few commands you may find useful in this video by SAS’ Darrell Barton.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 8 replies
  • 1031 views
  • 0 likes
  • 5 in conversation