BookmarkSubscribeRSS Feed
Madhan_cog1
Quartz | Level 8

Hi All,

We have installed and configured SAS 9.4 M5 Grid in a Linux Environment. when we installed/configured we did not configure the server as unicode server. Now as per the requirement we need to configure the server as unicode server.

What is the significance of configuring as Unicode server?

Could you pleas suggest the steps to manually configure the server as unicode server.

 

Madhan_cog1_1-1607347401658.png

 

Thanks,

Madhan M

11 REPLIES 11
Anand_V
Ammonite | Level 13

Hi @Madhan_cog1 

 

Few links for your reference.

What is Unicode? - https://en.wikipedia.org/wiki/Unicode

SAS® and UTF-8: Ultimately the Finest. - https://support.sas.com/resources/papers/proceedings17/SAS0296-2017.pdf

 

If you wish to change it on a system level (i.e. for all the sessions by default) you will have to update the system option ENCODING="utf-8" in the SASV9.cfg file.

 

Ref: https://go.documentation.sas.com/?cdcId=pgmsascdc&cdcVersion=9.4_3.5&docsetId=nlsref&docsetTarget=p1...

 

If you wish to do it on file level then you can pass the parameter in the program.

Ref: https://go.documentation.sas.com/?cdcId=pgmsascdc&cdcVersion=9.4_3.5&docsetId=nlsref&docsetTarget=n0...

 

 

Madhan_cog1
Quartz | Level 8

Hi Anand,

 

Thanks for the response.

Could you please let us know what all the files we should change and on which servers.

 

We could not see LOCALE and ENCODING Option in our SASv9.cfg file under SAS Foundation.

 

Should we set this manually or please suggest.

 

Thanks,

Madhan M.

gwootton
SAS Super FREQ
This documentation discusses creating a separate context for Unicode:
https://go.documentation.sas.com/?cdcId=bicdc&cdcVersion=9.4&docsetId=biasag&docsetTarget=n10001inte...
--
Greg Wootton | Principal Systems Technical Support Engineer
Madhan_cog1
Quartz | Level 8

Hi Greg,

Thanks for the response.

The link shows the steps to create a new Application server context and create a unicode out of it.

 

Is there a way to modify the existing server to be unicode. 

Could you please suggest.

 

Thanks,

Madhan M.

gwootton
SAS Super FREQ
You could make the same modifications described for the new context in that documentation to the existing one (e.g. SASApp).
--
Greg Wootton | Principal Systems Technical Support Engineer
Anand_V
Ammonite | Level 13

Hi @Madhan_cog1 

 

You will have to do this on all the servers where SASFoundation is installed if you wish to do this for every session that is spawned in the environment.

 

Once you have made the change you can verify the session properties by running proc options option=encoding; run;

 

Madhan_cog1
Quartz | Level 8

Hi Anand,

Thanks for the response.

/sas/apps/SASHome/SASFoundation/9.4/sasv9.cfg

 

Is this the only file to be modified in all the servers where SAS Foundation is installed.

Thanks,

Madhan M.

Anand_V
Ammonite | Level 13

Yes, that's right!

Madhan_cog1
Quartz | Level 8

Hi Anand,

 Thanks for the response.

 

We tried to change the sasv9.cfg file under SAS Foundation and added the Encoding as 

-ENCODING UTF-8

-LOCALE en_US

But the change is not reflecting as expected. 

 

It still shows the encoding as LATIN1.

 

Could you please suggest how to set the value for this file exactly.

 

Thanks,

Madhan M.

Anand_V
Ammonite | Level 13

Hi @Madhan_cog1 

 

Sorry, I misread the path before. Correct path should be

/sas/apps/SASHome/SASFoundation/9.4/nls/<current-encoding-value>/sasv9.cfg

 

It will already have parameter "-ENCODING <Value>" defined. Change the value to "UTF-8"

(all caps, no quotes)

ehbales
SAS Employee

Hi @Madhan_cog1,

 

Unfortunately, you cannot add the ENCODING option to the sasv9.cfg file that is directly under SASFoundation. Other resources are needed for SAS to successfully support UTF-8 as a session encoding.

 

The file /sas/apps/SASHome/SASFoundation/9.4/nls/u8/sasv9.cfg has the ENCODING option set to UTF-8 and is configured with the other resources you need. The script file /sas/apps/SASHome/SASFoundation/9.4/bin/sas_u8 is set up to use the UTF-8 version of the sasv9.cfg file. If you want every SAS session to run with UTF-8, you can change the 'sas' symbolic link in /sas/apps/SASHome/SASFoundation to point to the sas_u8 script file.

 

One word of caution: if you have created a server context and content with the LATIN1 encoding, you may see some encoding issues. It is usually safest to create a new context after you change the SAS encoding to ensure that it is set up correctly.

 

Thanks,
Elizabeth 

suga badge.PNGThe SAS Users Group for Administrators (SUGA) is open to all SAS administrators and architects who install, update, manage or maintain a SAS deployment. 

Join SUGA 

CLI in SAS Viya

Learn how to install the SAS Viya CLI and a few commands you may find useful in this video by SAS’ Darrell Barton.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 11 replies
  • 2149 views
  • 1 like
  • 4 in conversation