BookmarkSubscribeRSS Feed
🔒 This topic is solved and locked. Need further help from the community? Please sign in and ask a new question.
kselboe
Calcite | Level 5

Hi!

 

I have a problem with my distinct count in SAS VA. It returns 1 when I should get 0. It seems like the value is increased by 1 when I only have "missing fields" in the variable I performs the count on.

 

I found this in the documentation:

 

kselboe_0-1601363987187.png

Do anybody have a fix for this?

 

Best

Kristian

1 ACCEPTED SOLUTION

Accepted Solutions
Madelyn_SAS
SAS Super FREQ

There is an IgnoreMissingInCountDistinct property that you can enable to tell SAS Visual Analytics to ignore missing values in distinct counts. In Visual Analytics on SAS Viya, the property is set in sas.reportdata.properties

 

sas.reportdata properties

 

In Visual Analytics 7.x, the property is set in SAS Management Console. 

 

Properties Reference 

View solution in original post

1 REPLY 1
Madelyn_SAS
SAS Super FREQ

There is an IgnoreMissingInCountDistinct property that you can enable to tell SAS Visual Analytics to ignore missing values in distinct counts. In Visual Analytics on SAS Viya, the property is set in sas.reportdata.properties

 

sas.reportdata properties

 

In Visual Analytics 7.x, the property is set in SAS Management Console. 

 

Properties Reference 

sas-innovate-2024.png

 

Secure your spot at the must-attend AI and analytics event of 2024: SAS Innovate 2024! Get ready for a jam-packed agenda featuring workshops, super demos, breakout sessions, roundtables, inspiring keynotes and incredible networking events.

 

Register by March 1 to snag the Early Bird rate of just $695! Don't miss out on this exclusive offer. 

 

Register now!

Tips for filtering data sources in SAS Visual Analytics

See how to use one filter for multiple data sources by mapping your data from SAS’ Alexandria McCall.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 1 reply
  • 2422 views
  • 1 like
  • 2 in conversation