BookmarkSubscribeRSS Feed
☑ This topic is solved. Need further help from the community? Please sign in and ask a new question.
Dritan007
Fluorite | Level 6

Hello.


I have a table with 120 columns and 22k rows loaded into memory and promoted.
I add the columns 1 by 1 at a list table but when I added the first 4 columns (category type) the total rows reduced to 21k.
I continue adding more columns to the table and the total rows from the report keeps decreasing. I end up with 1700 rows.

Notice that I have selected "Detail Data" in the options to specify NOT to aggregate on any column.
It does not show any error though, while building the table.

Some columns have missing values too, but not all the columns at the same time. (At least 1 column is non-missing for every row).

 

Thank you for any help or suggestion.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Madelyn_SAS
SAS Super FREQ

The first thing to try is changing the Override system data limit on the Options tab for the object. If that does not work, then a midtier limit is being exceeded. Typically, we do not recommend changing those since they are in place for performance reasons. 

 

For more information, see https://support.sas.com/kb/62/148.html 

View solution in original post

5 REPLIES 5
Madelyn_SAS
SAS Super FREQ

Which version of Visual Analytics are you using? 

Dritan007
Fluorite | Level 6
Version 8.5.1
acordes
Rhodochrosite | Level 12

Visual Analytics is not designed for showing big tables. 

Its main purpose is to aggregate data. 

A table size limit kicks in and reduces the rows/columns combo accordingly.  

Even knowing this and designing the reports accordingly I have the need for exporting medium sized tables now and then. To circumvent the size limit I apply filters. 

Imagine a table with 30k rows and 40 columns, probably I have to subset the table by year or quarter (imagine a date variables for sales figures) in order to fiit all rows into the display prior to its export as excel.

 

BUT if this bothers you all the time you likely don't use Visual Analytics in the way it was intended for. 

Madelyn_SAS
SAS Super FREQ

The first thing to try is changing the Override system data limit on the Options tab for the object. If that does not work, then a midtier limit is being exceeded. Typically, we do not recommend changing those since they are in place for performance reasons. 

 

For more information, see https://support.sas.com/kb/62/148.html 

Dritan007
Fluorite | Level 6

Thank you very much.
defaultMaxCellsProduced had reached its limit.

sas-innovate-2024.png

Don't miss out on SAS Innovate - Register now for the FREE Livestream!

Can't make it to Vegas? No problem! Watch our general sessions LIVE or on-demand starting April 17th. Hear from SAS execs, best-selling author Adam Grant, Hot Ones host Sean Evans, top tech journalist Kara Swisher, AI expert Cassie Kozyrkov, and the mind-blowing dance crew iLuminate! Plus, get access to over 20 breakout sessions.

 

Register now!

Tips for filtering data sources in SAS Visual Analytics

See how to use one filter for multiple data sources by mapping your data from SAS’ Alexandria McCall.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 5 replies
  • 2474 views
  • 2 likes
  • 3 in conversation