BookmarkSubscribeRSS Feed
Matt
Quartz | Level 8

SAS VA LASR is not coming up from SAS VA Administrator webapp. However it is able to start with the program if I execute the program in SAS EG on VA application server.

 

With SAS VA administrator it keeps on complaining that PID file doesn't exist. It is not getting created from the SAS VA administrator but with the program it create PID file. User has read/write access, not exactly sure what the issues are.

 

ERROR: Physical file does not exist,
/opt/sas/config/Lev1/Applications/SASVisualAnalytics/VisualAnalyticsAdministrator/Monitoring/PIDs/smp_ustlvcmsp2328_1

 

Any help is appreciated. 

9 REPLIES 9
alexal
SAS Employee

@Matt,

 

How many application servers do you have in your environment? It appears that you have more than one application server and you are using an incorrect server in SAS Visual Analytics Administrator. Please go to File -> Properties -> Application Server and select correct application server for SAS Visual Analytics.

 

Also, if the SMP LASR server wasn't stopped gracefully. For an example, you stopped the object spawner without stopping SMP LASR first, you will get the following message:

 

Insufficient authorization to perform operation on file <PATH TO PID FILE>

 

In this case, the PID file has to be removed because the file got corrupted.

JuanS_OCS
Amethyst | Level 16

Hello @Matt,

 

the checks provided by @alexal are good ones to follow.

 

As an addition, I think it would be interesting to know:

- in SAS Management Console, how many application servers (SASApps) do you have.

- the user you use on EG to launch the program, and the SASApp you are connected to when running the program.

- the user you use to log on to SAS Visual Analytics Administrator.

- On each of the SASApps on SMC, please go to Logical Workspace Server, and the Properties. If you go to the Options tab, what Security Option do you have enabled: Host or SAS Token Authentication?

- In case you do have SAS Token Authentication, please go to Workspace Server (below Logical Workspace Server) , open the properties and in Option tab, what value/user do you have for Launch Credentials?

- Please run "ls -la /opt/sas/config/Lev1/Applications/SASVisualAnalytics/VisualAnalyticsAdministrator/Monitoring/PIDs" to know the ownership and permissions here.

 

 

Matt
Quartz | Level 8

@alexal

 

Thank you for your response and here is the details that you asked for. 

I removed PIDs multiple time, created it through the program from EG. It starts LASR but doesn't start Public LASR so not able to access any data or use other apps to create visuals. 

 

@JuanS

Thank you for your response and here is the details that you asked for. 

 

- in SAS Management Console, how many application servers (SASApps) do you have. :- 3

- the user you use on EG to launch the program, and the SASApp you are connected to when running the program.:- My personal ID which is a member of VA Administrator and other VA roles/groups. 

- the user you use to log on to SAS Visual Analytics Administrator. - Same as above

- On each of the SASApps on SMC, please go to Logical Workspace Server, and the Properties. If you go to the Options tab, what Security Option do you have enabled: Host or SAS Token Authentication? :- Host

- In case you do have SAS Token Authentication, please go to Workspace Server (below Logical Workspace Server) , open the properties and in Option tab, what value/user do you have for Launch Credentials? :- N/A

- Please run "ls -la /opt/sas/config/Lev1/Applications/SASVisualAnalytics/VisualAnalyticsAdministrator/Monitoring/PIDs" to know the ownership and permissions here. :- 666 see below


-rw-rw-rw- 1 savalim u-MserxX Jan 23 13:28 smp_usmaxse2104_10011.pid

alexal
SAS Employee

@Matt,

 

The main question here is: Are you sure that correct application server has been selected in the properties of SAS Visual Analytics Administrator? Go to File -> Properties -> Application Server. What is selected there?

Matt
Quartz | Level 8

Yes. SASAppVA - This is a work space server for VA non distributed. It appears there is some communication issues between and application server and mid-tier. 

alexal
SAS Employee

@Matt,

 

If you open SAS Technical Support Track, I will be able to help you through a WebEx.

Matt
Quartz | Level 8

Alexal,

 

I have a track open # 7612329268. A SAS TS person said since we rename SAS web app servers from SASServer1_1, 2_1, 11_1 and 12_1 to SASServer1,2,3 and 4, we are running into this issue and he requested to rebuild MidTier so before we do that I was trying to find if there are other ways to handle these issue.

alexal
SAS Employee

@Matt,

 

That was me and there are no other ways to solve this problem 🙂

Matt
Quartz | Level 8

Lol. Thank You.

Ready to join fellow brilliant minds for the SAS Hackathon?

Build your skills. Make connections. Enjoy creative freedom. Maybe change the world. Registration is now open through August 30th. Visit the SAS Hackathon homepage.

Register today!
Tips for filtering data sources in SAS Visual Analytics

See how to use one filter for multiple data sources by mapping your data from SAS’ Alexandria McCall.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 9 replies
  • 2784 views
  • 3 likes
  • 3 in conversation