BookmarkSubscribeRSS Feed
Fluorite | Level 6
I use a control (filter) on 2 layers:
- Report control filter
- Page control filter

The page filter is a drop down list with more than 500 variables, so the limit has been exceeded.
The report filter must first filter this page filter, then the number of variables is never more than 500.

In Report Designer this works as it should,
but in Report Viewer the drop down on the page filter doesn't want to filter. 

VA version: 7.5 release (9.4m6)

Does anyone know a way to fix this problem?, it would be nice to keep the drop down list on the page controls.
Fluorite | Level 6
Dear Madelyn,

It is the 7.5 Release (9.4m6) with the new html5 base.

Fluorite | Level 6

Hi Stephan - are you using different data sources for the report and page filter? Also, I'm not sure if report-level filters support Actions but you could try setting up a filtering action between the report and page filters. 



Fluorite | Level 6
Hi MClay,

thanks for your reply.
I use different data sources that I have mapped.
It works in the report designer, so there is a filter action between the report level filter and the page filter.
But in the report viewer, the action does not work.

I cannot set a filter action between the report and page filter, this is set by definition.


Don't miss out on SAS Innovate - Register now for the FREE Livestream!

Can't make it to Vegas? No problem! Watch our general sessions LIVE or on-demand starting April 17th. Hear from SAS execs, best-selling author Adam Grant, Hot Ones host Sean Evans, top tech journalist Kara Swisher, AI expert Cassie Kozyrkov, and the mind-blowing dance crew iLuminate! Plus, get access to over 20 breakout sessions.


Register now!

Tips for filtering data sources in SAS Visual Analytics

See how to use one filter for multiple data sources by mapping your data from SAS’ Alexandria McCall.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 4 replies
  • 1 like
  • 3 in conversation