BookmarkSubscribeRSS Feed
DartRodrigo
Lapis Lazuli | Level 10

Hi mates,

 

During these days i was editting a VA report, then after loading another table where there is nothing correlated with this main report,

my charts and dataset disappeared. The report is empty.

I've found this in SAS Support, but i'd like to know if there is something to repair it.

 

This problem can occur after the following steps are taken:

  1. The data source is altered in some way.
  2. After the data source is changed, the report is opened in one of these ways:
    • It is opened in SAS® Visual Analytics Viewer before it is opened in SAS® Visual Analytics Designer.
    • It is opened directly from the SAS® Visual Analytics Home Page into the Designer.
  3. If the report is opened in the Viewer, the report is then opened in the Designer for editing using the Edit Report button.
  4. In the Designer, because the data source has been modified, the Repair Report dialog box is displayed.
  5. The Fix All button is clicked in order to repair the report, and additional report changes are made.
  6. The report is saved.
  7. The next time anyone tries to open the report, the error appears.

Thanks in advance

3 REPLIES 3
Madelyn_SAS
SAS Super FREQ

I'm not entirely sure that the note you found is related to this issue. When you said that you loaded another table, do you mean you tried to add a second data source to the existing report? If so, did you use the option to Add data source or did you Change data source? If you changed the data source, you would have replaced your existing table.

 

If you did see the error "Unexpected second use of a unique name," then the next step is to open a Technical Support track and include the XML for the report. The instructions for getting the XML are in this note: http://support.sas.com/kb/54/676.html 

DartRodrigo
Lapis Lazuli | Level 10

No, actually i've loaded another data source, to view other report, when i re-openned the report i was working before, the sections disappeared.

And even i checked the option to see if one or more columns were deleted from the data source, but the table was in the report.

 

It is just like someone deleted all the sections in the report.

 

I couldn't find this in internet and there was only one person using and editing this report (Me), And I didn't delete anything.

 

Thanks

Madelyn_SAS
SAS Super FREQ

Is it possible that you are encountering this issue?

http://support.sas.com/kb/55/681.html

 

sas-innovate-2024.png

 

Secure your spot at the must-attend AI and analytics event of 2024: SAS Innovate 2024! Get ready for a jam-packed agenda featuring workshops, super demos, breakout sessions, roundtables, inspiring keynotes and incredible networking events.

 

Register by March 1 to snag the Early Bird rate of just $695! Don't miss out on this exclusive offer. 

 

Register now!

Tips for filtering data sources in SAS Visual Analytics

See how to use one filter for multiple data sources by mapping your data from SAS’ Alexandria McCall.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 3 replies
  • 1184 views
  • 0 likes
  • 2 in conversation