BookmarkSubscribeRSS Feed
🔒 This topic is solved and locked. Need further help from the community? Please sign in and ask a new question.
vandhan
Fluorite | Level 6

Hi,

 

When I open any SAS dataset I see column/variable label by default. 

I would like to see by default variable/column names instead of lables of these variables.

Is there any way/option for this?

 

Please help.

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
ballardw
Super User

If you are looking at this in Base SAS you should have gotten to an Edit Action box that already has the Action as &Open in the first line that  cannot be edited and the second line under Action Command that likely has the default value of: VIEWTABL %8B."%S".DATA

 

If you do see those two boxes than type the instruction AFTER the word DATA.

 

If not you are somewhere else in the system. Did you click on the Action &Open in the TABLE Options dialogue box?

View solution in original post

8 REPLIES 8
fusima
Calcite | Level 5

Hi,


there is an option to do that since SAS 9.2.

options nolabel;


Hope this helps you.

vandhan
Fluorite | Level 6
Hi Fusima,
Thanks for your time for replying my question.

This nolabel option removes all labels of the dataset.
But, I need to have labels for dataset and I wanted to see variable names
by default when I open dataset.

Please help.

##- Please type your reply above this line. Simple formatting, no
attachments. -##
ballardw
Super User

In Base SAS:

Make SAS Explorer the active Window

From the menu bar select Tools>Options>Explorer

Go to the Members Tab and double click on Table

Select the &Open entry and click

Add the text: colheading=name

to the action command.

Close out of everything using the appropriate buttons.

vandhan
Fluorite | Level 6
Hi,

Thanks for you reply.

It is not going through. What should be in the "Action"??
Action : (what should i enter here)
Action Command : colheading=name



##- Please type your reply above this line. Simple formatting, no
attachments. -##
ballardw
Super User

If you are looking at this in Base SAS you should have gotten to an Edit Action box that already has the Action as &Open in the first line that  cannot be edited and the second line under Action Command that likely has the default value of: VIEWTABL %8B."%S".DATA

 

If you do see those two boxes than type the instruction AFTER the word DATA.

 

If not you are somewhere else in the system. Did you click on the Action &Open in the TABLE Options dialogue box?

vandhan
Fluorite | Level 6
Got it. Thanks for your time
evp000
Quartz | Level 8

Hello,

 

I have this option set to view column names.  If I open a data by navigating there with SAS explorer using a shortcut to the actual directory, and click on it, I see the labels in VIEWTABLE.  If I navigate to the same directory using the SAS library, I see the variable names.  Very weird.  Can it be changed so that I can see the variable names at all times?

 

Thanks.

Ready to join fellow brilliant minds for the SAS Hackathon?

Build your skills. Make connections. Enjoy creative freedom. Maybe change the world. Registration is now open through August 30th. Visit the SAS Hackathon homepage.

Register today!
How to Concatenate Values

Learn how use the CAT functions in SAS to join values from multiple variables into a single value.

Find more tutorials on the SAS Users YouTube channel.

Click image to register for webinarClick image to register for webinar

Classroom Training Available!

Select SAS Training centers are offering in-person courses. View upcoming courses for:

View all other training opportunities.

Discussion stats
  • 8 replies
  • 11942 views
  • 3 likes
  • 5 in conversation