BookmarkSubscribeRSS Feed
🔒 This topic is solved and locked. Need further help from the community? Please sign in and ask a new question.
kmj636
Obsidian | Level 7

Hi,

 

I created a number of numeric variables (which calculate based on previous variables) and all but one is displaying. I used a putlog statement to see what was happening on the back end and the variable and corresponding observations are being displayed appropriately in the log, BUT are displaying in the results as a missing number. Any suggestions on how to trouble shoot this?

 

Thank you for any help and your time -

1 ACCEPTED SOLUTION

Accepted Solutions
RW9
Diamond | Level 26 RW9
Diamond | Level 26

"Any suggestions on how to trouble shoot this?" - Start by following how to post a question.  Provide test data in the form of a datastep.  Then provide the code you are running, and the log.  Also explain why the output does not match your expectations.  Could be any number of things.

View solution in original post

4 REPLIES 4
RW9
Diamond | Level 26 RW9
Diamond | Level 26

"Any suggestions on how to trouble shoot this?" - Start by following how to post a question.  Provide test data in the form of a datastep.  Then provide the code you are running, and the log.  Also explain why the output does not match your expectations.  Could be any number of things.

Reeza
Super User

I used a putlog statement to see what was happening on the back end and the variable and corresponding observations are being displayed appropriately in the log, BUT are displaying in the results as a missing number. 

 

Somewhere between your PUTLOG and the results something changes? Check the code for the missing variable. 

 

Without code or anything else, this is going to be a game of 20 questions. 

kmj636
Obsidian | Level 7

Ok sorry about that. I should know better by now about posting questions without code. 

 

I actually just closed the data set right before the final variable and created a new one which just creates the final var and that seemed to solve the problem. So maybe I was placing my statements in an order that was not making SAS happy?

 

Not sure but as always, I do appreciate the time and help. Next time, I promise to post my code with my questions.

 

Thank you again -

Reeza
Super User

Again without code this is a guess, but you can't replace a data set while it's open. Make sure to check your log in the future, the errors are usually noted there.

Ready to join fellow brilliant minds for the SAS Hackathon?

Build your skills. Make connections. Enjoy creative freedom. Maybe change the world. Registration is now open through August 30th. Visit the SAS Hackathon homepage.

Register today!
How to Concatenate Values

Learn how use the CAT functions in SAS to join values from multiple variables into a single value.

Find more tutorials on the SAS Users YouTube channel.

Click image to register for webinarClick image to register for webinar

Classroom Training Available!

Select SAS Training centers are offering in-person courses. View upcoming courses for:

View all other training opportunities.

Discussion stats
  • 4 replies
  • 523 views
  • 1 like
  • 3 in conversation