BookmarkSubscribeRSS Feed
☑ This topic is solved. Need further help from the community? Please sign in and ask a new question.
samlki
Calcite | Level 5

I am using SAS EG 7.13 on Win 10. Today I realized that hotkeys with the Ctrl key are not working. So, when i press Ctrl + F or  Ctrl + H or Ctrl + G, nothing happens.

I tried to select the find option from the menue bar (View/Find), it is not working there also.

 

Anyone has come across the same problem?

Appreciate your thoughts.

 

Meysam

Meysam
1 ACCEPTED SOLUTION

Accepted Solutions
JoshB
Quartz | Level 8

Do you ever connect to any external monitors? I have found at times that my Find popup window will get moved to another screen that is later disconnected and no longer will show on my single laptop monitor. It seems as though it isn't working, but in reality it's just completely off screen and invisible. It's a very odd issue as it doesn't always happen, but when it does, my only way I've found to fix it is to restart the computer with no external monitors attached. The Find popup window will then open on my screen correctly.

 

Also seeSAS EG - lost search window:

If you suspect that you have a window that's "in focus" but off screen, use these keyboard shortcuts:

 

   Alt+SPACE, then M, then use the arrow keys to move the window into view.

 

Practice a few times with your multiple displays to get the hang of it.

 

EG *should* detect that a window is out-of-view and move it into the primary display if needed, but it's possible that there is an instance or two where this isn't happening.  If you have a repeatable case, report it to SAS Tech Support and I'm sure the product team will address it.

 

 

 

View solution in original post

10 REPLIES 10
andreas_lds
Jade | Level 19

The oldest EG i have access to is 7.15 and i ctrl+f is working as expected. I would start with re-installing EG, maybe applying the latest updates helps.

JoshB
Quartz | Level 8

Do you ever connect to any external monitors? I have found at times that my Find popup window will get moved to another screen that is later disconnected and no longer will show on my single laptop monitor. It seems as though it isn't working, but in reality it's just completely off screen and invisible. It's a very odd issue as it doesn't always happen, but when it does, my only way I've found to fix it is to restart the computer with no external monitors attached. The Find popup window will then open on my screen correctly.

 

Also seeSAS EG - lost search window:

If you suspect that you have a window that's "in focus" but off screen, use these keyboard shortcuts:

 

   Alt+SPACE, then M, then use the arrow keys to move the window into view.

 

Practice a few times with your multiple displays to get the hang of it.

 

EG *should* detect that a window is out-of-view and move it into the primary display if needed, but it's possible that there is an instance or two where this isn't happening.  If you have a repeatable case, report it to SAS Tech Support and I'm sure the product team will address it.

 

 

 

andreas_lds
Jade | Level 19

Have a look at %AppData%\SAS\EnterpriseGuide\$VERSION, there are several xml-files in the directory containing window-positions. Deleting the right file (while EG is closed) should solve that problem.

Pochemuchka
Fluorite | Level 6

I had same issue all of a sudden today in the middle of day. Updating Windows and SAS EG didn't help, neither restarting laptop without extended screens. Luckily I found solution here:
https://support.sas.com/kb/47/355.html

  1. Close SAS Enterprise Guide.
  2. Select Start ► Run ► Regedit.
  3. Expand to HKEY_CURRENT_USER\Software\SAS Institute Inc.\Enhanced Editor\BIC_7.1\Search History.
  4. In the left panel, right-click on Search History and select Delete.
  5. Expand to HKEY_CURRENT_USER\Software\SAS Institute Inc.\Enhanced Editor\BIC_8.1\Search History.
  6. In the left panel, right-click on Search History and select Delete
  7. Close the registry window, and then restart SAS Enterprise Guide.

I thought to share in case if there was anyone else pulling hair out because of suddenly disabled Edit option in SAS EG.

redraider90
Calcite | Level 5

thank you very, very much! This helped me with the exact same problem I was experiencing!

SASKiwi
PROC Star

@redraider90  - Shifting to EG 8 also fixes this problem and it has better multi-screen functionality.

redraider90
Calcite | Level 5
I’m on EG 9.4 I believe. I’ll double check that but I believe that’s what ver I’m on and still got this error.
Thanks, though.
SASKiwi
PROC Star

@redraider90  - That's the SAS version, not the EG one. In EG you can check the EG version using the Help - About menu option.

yp2609
Fluorite | Level 6

Thank you so much!

Venerable
Calcite | Level 5
This post is very old, but for the sake of future SAS users, there's a much easier method to fix this than has been suggested by other comments.

Simply open any SAS script and press ctrl+f. Do not press or click anything else. You'll notice your SAS session now has a greyed window meaning the 'find' box HAS opened (just off screen).

Now hold alt and press spacebar then 'M'. A multidirectional arrow will appear at the edge of your screen. Hold the relevant arrow key until the search box reappears on screen.

Voila! Be sure to use your mouse to move the search box or else you'll need to repeat these steps.

Ready to join fellow brilliant minds for the SAS Hackathon?

Build your skills. Make connections. Enjoy creative freedom. Maybe change the world. Registration is now open through August 30th. Visit the SAS Hackathon homepage.

Register today!
How to Concatenate Values

Learn how use the CAT functions in SAS to join values from multiple variables into a single value.

Find more tutorials on the SAS Users YouTube channel.

Click image to register for webinarClick image to register for webinar

Classroom Training Available!

Select SAS Training centers are offering in-person courses. View upcoming courses for:

View all other training opportunities.

Discussion stats
  • 10 replies
  • 19520 views
  • 14 likes
  • 8 in conversation