BookmarkSubscribeRSS Feed
🔒 This topic is solved and locked. Need further help from the community? Please sign in and ask a new question.
AbuChowdhury
Fluorite | Level 6

Hi Experts,

 

I was trying to do the GMM estimation in proc panel. But I see that AR test result is blank. It shows the following message in the log file:

 

WARNING: The ARTEST test cannot be calculated for one or more lags due to missing values in the
response and/or explanatory variable.

 

It shows the same message even if I removed the missing observations for my selected variables. How can I address this issue? is there other ways except proc panel to estimate GMM?

1 ACCEPTED SOLUTION

Accepted Solutions
bobby_sas
SAS Employee

 

AbuChowdhury emailed me his data, and we were able to ascertain that his missing AR test was caused by gaps in the time series for one or more of the firms in his data.   

 

 

View solution in original post

5 REPLIES 5
bobby_sas
SAS Employee

This seems an odd error message.  It may be the case that the problem does not lie with the model regression itself, but from estimation of some auxiliary model used for either starting values or as the basis for a specification test.  If that's the case then the error message is cryptic and could be improved upon, so that it can provide more specific guidance.

 

If Abu can email me the data (or some subset) and code that reproduces the problem, I'll be glad to take a closer look and give a more specific diagnosis.

AbuChowdhury
Fluorite | Level 6

Hi,

 

I will send you the partial dataset to your email. Please provide me your email address. My email address is rasel0608@yahoo.com. I will send you the dataset from this email.

bobby_sas
SAS Employee

 

AbuChowdhury emailed me his data, and we were able to ascertain that his missing AR test was caused by gaps in the time series for one or more of the firms in his data.   

 

 

mspak
Quartz | Level 8

Dear bobby_sas,

 

I also encountered the same problem and receive the following warnings:

 

WARNING: The ARTEST test cannot be calculated for one or more lags due to missing values in the
response and/or explanatory variable.

 

However, I am still unsure how to solve the problem by reading the posts in this forum. Could you please share with me as I need to get the AR1 and AR2 test results.

 

Thank you.

 

MSPAK

bobby_sas
SAS Employee

 

Dear mspak,

 

I gave the following explanation in another thread:

 

If the missing values are due to calculations performed by PROC PANEL when generating lagged variables, then this can be alleviated by using the CLAG statement (instead of the LAG statement).  This will replace missing values with cross-sectional means.  Otherwise, you would have to manually exclude the "missing" observations from the analysis by using the WHERE= option. 

 

--Bobby

sas-innovate-2024.png

Available on demand!

Missed SAS Innovate Las Vegas? Watch all the action for free! View the keynotes, general sessions and 22 breakouts on demand.

 

Register now!

Multiple Linear Regression in SAS

Learn how to run multiple linear regression models with and without interactions, presented by SAS user Alex Chaplin.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 5 replies
  • 2346 views
  • 1 like
  • 3 in conversation