BookmarkSubscribeRSS Feed
mspak
Quartz | Level 8

Dear all,

 

I get an error messge as follows:

 

The ARTEST test cannot be calculated for one or more lags due to missing values in the response and/or explanatory variable.

 

May I know how can I overcome this problem?

 

Thank you.

3 REPLIES 3
Ksharp
Super User

Which PROC are you using ?

Maybe you should use PROC EXPAND to interpolate these missing value .

mspak
Quartz | Level 8

Hi,

 

proc panel data=Ad5;
instruments depvar ;
model AD = LAGXAD MB SGWTH CASH_AT1 CHG_WC YR01 YR02 YR03 YR04
YR05 YR06 YR07 YR08 YR09 YR10-YR15 IND01 IND04 IND05 IND06 IND07 IND08 IND09 IND10
/ gmm twostep maxband=5 artest = 2;
id gvkey fyear;
run;

 

It is a AR test in proc panel.

TBeans
Fluorite | Level 6

I get the same problem with the AR test in PROC PANEL even when my data are all non-missing.

To double check I ran:

 

proc means data = model_testing3 NMISS N;
RUN;	

And indeed, all NMISS = 0.

 

In fact even when I try to remove the missing lags myself (before invoking PROC PANEL) the same error of "missing values" occurs.  

 

I really hope the error isn't because PROC PANEL generates missing values when it takes first differences and takes the "appropriate lags" of depvar... but I don't see what else it could be.

sas-innovate-2024.png

Don't miss out on SAS Innovate - Register now for the FREE Livestream!

Can't make it to Vegas? No problem! Watch our general sessions LIVE or on-demand starting April 17th. Hear from SAS execs, best-selling author Adam Grant, Hot Ones host Sean Evans, top tech journalist Kara Swisher, AI expert Cassie Kozyrkov, and the mind-blowing dance crew iLuminate! Plus, get access to over 20 breakout sessions.

 

Register now!

Multiple Linear Regression in SAS

Learn how to run multiple linear regression models with and without interactions, presented by SAS user Alex Chaplin.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 3 replies
  • 1132 views
  • 1 like
  • 3 in conversation