BookmarkSubscribeRSS Feed
ncsthbell
Quartz | Level 8
I have created 3 prompts in query builder. The first time I run the query builder the prompts come up just fine. When I select to 'run' the query builder after this initial time, the prompts do not present although they are still defined in the query builder. I have had to delete & add them back in each time I run the query builder. Any ideas on why the prompts are defined but not presenting? I also have the filters for these columns set to the prompts.

thanks
1 REPLY 1
ChrisHemedinger
Community Manager
When you re-run the process flow, the prompts should show again -- as long as the prompts are correctly associated with the query (which they should be if you selected them via point-and-click). If you referenced the prompts in the query simply by typing in the macro variable, that isn't good enough.

You can also check the query properties (right-click on the query node, Properties) and make sure that the prompts you need are in the Prompts list.

If this isn't working for you I recommend checking with SAS Technical Support.

Chris
Check out SAS Innovate on-demand content! Watch the main stage sessions, keynotes, and over 20 technical breakout sessions!

sas-innovate-2024.png

Available on demand!

Missed SAS Innovate Las Vegas? Watch all the action for free! View the keynotes, general sessions and 22 breakouts on demand.

 

Register now!

SAS Enterprise Guide vs. SAS Studio

What’s the difference between SAS Enterprise Guide and SAS Studio? How are they similar? Just ask SAS’ Danny Modlin.

Find more tutorials on the SAS Users YouTube channel.

Click image to register for webinarClick image to register for webinar

Classroom Training Available!

Select SAS Training centers are offering in-person courses. View upcoming courses for:

View all other training opportunities.

Discussion stats
  • 1 reply
  • 659 views
  • 0 likes
  • 2 in conversation