BookmarkSubscribeRSS Feed
🔒 This topic is solved and locked. Need further help from the community? Please sign in and ask a new question.
arda
Calcite | Level 5

Hi,

I am taking an eLearning class "Applied Analytics Using SAS Enterprise Miner" . I am going through the slides and in regression I had an issue.

When I use the default Entry and Stay Significance Levels, analysis works exactly the same way as the one in the class. When the virtual instructor tells me to change the Entry Significance Level to 1.0 and Stay Significance Level to 0.5 (not 0.05), I do exactly the same. But I can't get the same result. I tried to figure out this with a friend who knows a great deal about EM but he couldn't come up with a solution. He thinks that it may be an issue with version.

Because, the course is for EM 7.1. It doesn't have a course for EM 12.1

What do you think?

1 ACCEPTED SOLUTION

Accepted Solutions
jwexler
SAS Employee

Arda, sorry to hear about your issue.  I think I have the solution Smiley Happy

When you go to selection options, change the maximum number of steps to a large integer, say 30.  What's happening behind the scenes is that the default number of steps is set to the number of effects when you select default.  When you select to use your own settings, the default number of steps is set to 0 in the dialogue.

Thanks,

Jonathan

View solution in original post

4 REPLIES 4
arda
Calcite | Level 5

I must also add the default values are 0.05 for entry and 0.05 for stay.

In order to figure out what is wrong, I am choosing "Use Default Values" as No and using the same default values and having the problem. The problem is it only selects the intercept. No other effects. But in the course, it has 16 effects.

jwexler
SAS Employee

Arda, sorry to hear about your issue.  I think I have the solution Smiley Happy

When you go to selection options, change the maximum number of steps to a large integer, say 30.  What's happening behind the scenes is that the default number of steps is set to the number of effects when you select default.  When you select to use your own settings, the default number of steps is set to 0 in the dialogue.

Thanks,

Jonathan

arda
Calcite | Level 5

Wow, this is great. It worked like a charm. Thanks a bunch.

Do you think that this is because of the version?

jwexler
SAS Employee

Glad it worked!  We changed our defaults after 7.1, so this is something we will make a note of in our training.  Thanks!

sas-innovate-2024.png

Available on demand!

Missed SAS Innovate Las Vegas? Watch all the action for free! View the keynotes, general sessions and 22 breakouts on demand.

 

Register now!

How to choose a machine learning algorithm

Use this tutorial as a handy guide to weigh the pros and cons of these commonly used machine learning algorithms.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 4 replies
  • 1185 views
  • 3 likes
  • 2 in conversation