BookmarkSubscribeRSS Feed
🔒 This topic is solved and locked. Need further help from the community? Please sign in and ask a new question.
Shrutibhatnagar
Obsidian | Level 7
1 OPTIONS NONOTES NOSTIMER NOSOURCE NOSYNTAXCHECK;
72
73 proc sql outobs=20;
74 select * ,new_column
75 from class1.smb
76 left join work.mismatches2
77 on smb.product_id=mismatches2.product_id;
ERROR: Insufficient space in file WORK.'SASTMP-000000068'n.UTILITY.
ERROR: File WORK.'SASTMP-000000068'n.UTILITY is damaged. I/O processing did not complete.
NOTE: Error was encountered during utility-file processing. You may be able to execute the SQL statement successfully if you
allocate more space to the WORK library.
ERROR: There is not enough WORK disk space to store the results of an internal sorting phase.
ERROR: An error has occurred.
NOTE: PROC SQL set option NOEXEC and will continue to check the syntax of statements.
78 quit;
NOTE: The SAS System stopped processing this step because of errors.
NOTE: PROCEDURE SQL used (Total process time):
real time 25.87 seconds
cpu time 14.17 seconds
 
79
80
81 OPTIONS NONOTES NOSTIMER NOSOURCE NOSYNTAXCHECK;
93
 
 
 
 
 
i tried to increase the size of my vm to its maxmum limit also then also these errors get generated ,
is my code even getting executed ? or its just some  problem with my vm ?
1 ACCEPTED SOLUTION

Accepted Solutions
Kurt_Bremser
Super User

If you are working with UE, it may also be that forcibly terminated sessions have clogged up the VM (it has a maximum internal space if 10 GB, and that limits the WORK location). To remedy that, you need to re-install UE.

Please show us the sizes of yor datasets (number of obs, observation size)

View solution in original post

2 REPLIES 2
Tom
Super User Tom
Super User

How large are the datasets you are merging?
Why not just use a data step instead of letting PROC SQL fill up your disk space with temporary files?

 

data _null_;
  merge class1.smb work.mismatches2;
  by product_id ;
  put (_all_) (=);
  if _n_ > 20 then stop;
run;
Kurt_Bremser
Super User

If you are working with UE, it may also be that forcibly terminated sessions have clogged up the VM (it has a maximum internal space if 10 GB, and that limits the WORK location). To remedy that, you need to re-install UE.

Please show us the sizes of yor datasets (number of obs, observation size)

CFC_SAS_Communities_400x225.jpg

Call for content now open!

It's your turn to help shape SAS Innovate 2027. Share your expertise and inspire the SAS community.

Submit your proposal →

Develop Code with SAS Studio

Get started using SAS Studio to write, run and debug your SAS programs.

Find more tutorials on the SAS Users YouTube channel.

SAS Training: Just a Click Away

 Ready to level-up your skills? Choose your own adventure.

Browse our catalog!

Discussion stats
  • 2 replies
  • 3101 views
  • 3 likes
  • 3 in conversation