BookmarkSubscribeRSS Feed
🔒 This topic is solved and locked. Need further help from the community? Please sign in and ask a new question.
Kastchei
Pyrite | Level 9

I am using ODF PDF, and I trying to figure out a way to turn off bold in titles.  Here are the things I've tried.  In all of these cases, the title is still bold.  Footnotes, however, are not bold.  Any suggestions?

 

  1. Changing the font in the TITLE statement, which is supposed to clear bold.  E.g.:
    title1 height = 8pt font = 'Arial' justify = left 'title ' justify = right "more title ";
  2. Adding escape character style information.  E.g.:
    ods escapechar = '`';
    title1 height = 8pt font = 'Arial' justify = left '`{style [fontWeight=light]}title ' justify = right "more title ";
  3. Changing the template.  E.g.:
    proc template;
        define style pearlEdit;
            parent = styles.pearl;
            style fonts /
                'TitleFont2'          = ("Arial"                    , 8pt)
                'TitleFont'           = ("Arial"                    , 8pt)
                'StrongFont'          = ("Arial"                    , 8pt)
                'EmphasisFont'        = ("Arial"                    , 8pt)
                'FixedEmphasisFont'   = ("<monospace>, Courier"               , 8pt)
                'FixedStrongFont'     = ("<monospace>, Courier"               , 8pt)
                'FixedHeadingFont'    = ("<monospace>, Courier"               , 8pt)
                'BatchFixedFont'      = ("SAS Monospace, <monospace>, Courier", 8pt)
                'FixedFont'           = ("<monospace>, Courier"               , 8pt)
                'headingEmphasisFont' = ("Arial"                    , 8pt)
                'headingFont'         = ("Arial"                    , 8pt)
                'docFont'             = ("Arial"                    , 8pt);
        end;
    run;
    ods pdf file = "My PDF.pdf" style = pearlEdit;
1 ACCEPTED SOLUTION

Accepted Solutions
Kastchei
Pyrite | Level 9

I figured it out!  I was plotting a graph using sgplot, and the titles were becoming part of the graph, using the style for the graph rather than the document.  I added noGTitle and noGFootnote to my ODS PDF statement, and now the constant bold is gone.

 

It might be a bug that bold cannot be turned off with gTitle.

 

Sorry if I wasted anyone's time.

View solution in original post

2 REPLIES 2
Kastchei
Pyrite | Level 9

I figured it out!  I was plotting a graph using sgplot, and the titles were becoming part of the graph, using the style for the graph rather than the document.  I added noGTitle and noGFootnote to my ODS PDF statement, and now the constant bold is gone.

 

It might be a bug that bold cannot be turned off with gTitle.

 

Sorry if I wasted anyone's time.

ballardw
Super User

If you don't need the Title behavior of repeating for different procedures or the use of the #By directives you might try "

1) no title at all

2) ODS Text or Proc ODSTEXT to place text before a graph object.

Ready to join fellow brilliant minds for the SAS Hackathon?

Build your skills. Make connections. Enjoy creative freedom. Maybe change the world. Registration is now open through August 30th. Visit the SAS Hackathon homepage.

Register today!
How to Concatenate Values

Learn how use the CAT functions in SAS to join values from multiple variables into a single value.

Find more tutorials on the SAS Users YouTube channel.

Click image to register for webinarClick image to register for webinar

Classroom Training Available!

Select SAS Training centers are offering in-person courses. View upcoming courses for:

View all other training opportunities.

Discussion stats
  • 2 replies
  • 3887 views
  • 4 likes
  • 2 in conversation