BookmarkSubscribeRSS Feed
🔒 This topic is solved and locked. Need further help from the community? Please sign in and ask a new question.
kpberger
Obsidian | Level 7

Hello. Not sure where to put this question, but is there any way to have SAS not open the explorer and results windows by default? I always close them immediately. Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
DaveHorne
SAS Employee

Since I'm old school, I put these in my local SAS config file:
-FONT 'Consolas' 10
-awstitle "SAS 9.4M7 x64 UTF-8"
-noenhancededitor
-nodmsexp
You can also use the same options on your SAS desktop shortcut alternatively.

 

EDIT:  I also arrange my windows and use the "WSAVE ALL" command as mentioned earlier.

View solution in original post

7 REPLIES 7
Reeza
Super User
Yes, what type of software do you have, EG, Studio, Base?

There's an option in preferences to display results as generated as well ODS options to supress results as needed.

kpberger
Obsidian | Level 7

Yes, sorry I am running base SAS 9.4.

 

I don't want to suppress results as they are reported. I want SAS to boot up showing only the log and editor windows. I'm find if the results window pops up later when I'm running things.

Reeza
Super User
Ah....that's something I don't know then 😞
FreelanceReinh
Jade | Level 19

Hello @kpberger,

 

Try this:

  1. Close all SAS sessions.
  2. Open a SAS session with system option NORSASUSER.
  3. Arrange the windows as you like.
  4. Enter WSAVE ALL in the command line and press Return.¹
  5. Close the SAS session.

This should save the window arrangement in your user profile catalog. Make sure that it is not overwritten accidentally by the "Save settings on exit" feature in Tools → Options → Preferences... → General, if NORSASUSER is your standard option setting.

 

¹ I can't find the WSAVE command in the online documentation, only in the built-in help files of my Windows SAS 9.4M5.

kpberger
Obsidian | Level 7

Hi, thanks for your response. Those steps didn't work and I think it's because "This command [WSAVE ALL] saves the global settings, such as window color and window position, that are in effect for all windows that are currently open." (http://www.math.wpi.edu/saspdf/vms/c04.pdf) So it seems like it wouldn't work for closed windows which is rather a catch 22.

 

I did verify the steps worked to change the size of a window (I now have SAS open with the editor maximized which I also prefer so thank you).

DaveHorne
SAS Employee

Since I'm old school, I put these in my local SAS config file:
-FONT 'Consolas' 10
-awstitle "SAS 9.4M7 x64 UTF-8"
-noenhancededitor
-nodmsexp
You can also use the same options on your SAS desktop shortcut alternatively.

 

EDIT:  I also arrange my windows and use the "WSAVE ALL" command as mentioned earlier.

kpberger
Obsidian | Level 7
-nodmsexp did it. Thank you!!

sas-innovate-2024.png

Available on demand!

Missed SAS Innovate Las Vegas? Watch all the action for free! View the keynotes, general sessions and 22 breakouts on demand.

 

Register now!

Mastering the WHERE Clause in PROC SQL

SAS' Charu Shankar shares her PROC SQL expertise by showing you how to master the WHERE clause using real winter weather data.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 7 replies
  • 1701 views
  • 4 likes
  • 4 in conversation