BookmarkSubscribeRSS Feed
☑ This topic is solved. Need further help from the community? Please sign in and ask a new question.
kimjj
Fluorite | Level 6

Hi,

 

I can't seem to make the SAS extension for VS code to work with my local SAS installation nor the remote SAS installation (Linux).  I followed the instructions here - vscode-sas-extension/connect-and-run.md at main · sassoftware/vscode-sas-extension (github.com) and many other places.

 

First of all, I don't even get the running man icon show up so I can't try to run the SAS code.  I have the latest VS code and SAS extension installed but nothing seems to be working.

 

Thanks,

James

 

1 ACCEPTED SOLUTION

Accepted Solutions
kimjj
Fluorite | Level 6

I solved the issue - there was another SAS extension I was using previously that seemed to be interfering with the official SAS extension.  I removed it and now it works.

 

Thank you all!

James

View solution in original post

6 REPLIES 6
JuanS_OCS
Amethyst | Level 16

Hi James,

 

the latest version 1.7.1 did not work for me either. At least for local connections, 1.6.0 works for me, you need to downgrade the extension.

Remote IOM connections don't work for me for now, and remote SSH connections I assume it works, but I did not try that since: a) I am not a fan, and b)I would only be able to make Metadata connections from the code on itself.

kimjj
Fluorite | Level 6
So it's broken in the latest version...? That doesn't sound good. Rather than downgrading, I'd rather see this problem fixed in the next release but how do you downgrade exactly (so I can verify it works on my installation)? Thanks.
JuanS_OCS
Amethyst | Level 16
I cannot say it is broken, it just does not work for me. Could be a local configuration issue.
To downgrade a version, if you go to the installed extension, under the Uninstall button if you click on the drop-down button "V", it will allow you to install a different version.
kimjj
Fluorite | Level 6
Downgrading didn't work for me. So the version is not the issue here.
ChrisHemedinger
Community Manager

@kimjj I suggest you report this using GitHub Issues on the project and provide as many details as possible.

 

https://github.com/sassoftware/vscode-sas-extension/issues

Check out SAS Innovate on-demand content! Watch the main stage sessions, keynotes, and over 20 technical breakout sessions!
kimjj
Fluorite | Level 6

I solved the issue - there was another SAS extension I was using previously that seemed to be interfering with the official SAS extension.  I removed it and now it works.

 

Thank you all!

James

sas-innovate-2024.png

Available on demand!

Missed SAS Innovate Las Vegas? Watch all the action for free! View the keynotes, general sessions and 22 breakouts on demand.

 

Register now!

Discussion stats
  • 6 replies
  • 904 views
  • 2 likes
  • 3 in conversation