BookmarkSubscribeRSS Feed
AndersBergquist
Quartz | Level 8

My problem is this.

I have delvelop a report with EG there I use proc surveymeans. The problem with proc surveymeans is that there is no noprint option to prevent output. I thought I could solve it with "ods listing close".

But then I create a SP, the output was there. I can turn all of with "ods _all_ close" but then, there is no way to turn the rigth ods on and I got no output, even the desired output. Can someone help me to solve this problem?

1 REPLY 1
NN
Quartz | Level 8 NN
Quartz | Level 8

Hi,

I think you can try and use the _webout for printing your required report.

First thing In your STP uncheck the option "Stored Process Macros" under "Include Code For"

select Stored Process Sever   ---and Streaming Output as your execution Options

Then as per the below code whatever staments you write between you ods html should only be displayed in your output.

proc print data=sashelp.shoes;

run;

 

ods html body=_webout;

proc print data=sashelp.class;

run;

ods html close;

Hope this helps...

sas-innovate-2024.png

Available on demand!

Missed SAS Innovate Las Vegas? Watch all the action for free! View the keynotes, general sessions and 22 breakouts on demand.

 

Register now!

How to Concatenate Values

Learn how use the CAT functions in SAS to join values from multiple variables into a single value.

Find more tutorials on the SAS Users YouTube channel.

Click image to register for webinarClick image to register for webinar

Classroom Training Available!

Select SAS Training centers are offering in-person courses. View upcoming courses for:

View all other training opportunities.

Discussion stats
  • 1 reply
  • 1169 views
  • 0 likes
  • 2 in conversation