BookmarkSubscribeRSS Feed
Calcite | Level 5

I have searched community and found a couple of similar questions. It seems the solution for this question is to seek help from SAS support which I did but no response yet. I am re-posting this question to see if there is anyone have a quick solution for this issue.


I used to work on Windows 7 and running SAS 9.4 32 bit without this problem. I just had Windows 10 installed and tried SAS 9.4 32 bit and the crashes start. Then our IT installed SAS 9.4 64 bit, the problem still happens. The problem happens no matter the size of the data set is. SAS will crash on a big data set or a small data set with only one row. But it seems it only happens when I try to view a data set I just created in the work library. And this problem happens spontaneously. 



Jade | Level 19

Hello @Junsc and welcome to the SAS Support Communities!

@Junsc wrote:

I have searched community and found a couple of similar questions.

So, I assume you found the one year old thread where someone suggested a specific change to the Windows registry and Chris Hemedinger mentioned a possibly helpful SAS system option? If not, you would also find there my standard recommendation regarding problems with the ViewTable window: Don't use it and use the SAS Universal Viewer instead. Being a separate program -- you could use it even without a SAS installation --, it will much less likely affect the stability of your SAS session.


Years ago I had a somewhat similar issue with the built-in help files ("SAS Help and Documentation" window opened via the Help menu). They often let my Windows 7 system crash with a BSOD ("blue screen"). Since I switched to using the SAS Documentation Viewer 9.4 (which runs independently of the SAS session, offline; several instances of it can be opened; it's part of a standard PC-SAS installation) this has never happened again.


That said, I agree that this is a good question for SAS Technical Support.

Calcite | Level 5

Thanks FreelanceReinhard. I have not tried to change windows registry or other actions. But SAS responded my question and told me how to recover the SAS session by accessing and to resume the SAS from procexp.exe. This action is kind of resolved the problem but it also alerts the IT department of my agency. So, I will not try it again till was told it's safe.



Registration is open! SAS is returning to Vegas for an AI and analytics experience like no other! Whether you're an executive, manager, end user or SAS partner, SAS Innovate is designed for everyone on your team. Register for just $495 by 12/31/2023.

If you are interested in speaking, there is still time to submit a session idea. More details are posted on the website. 

Register now!

Discussion stats
  • 2 replies
  • 1 like
  • 2 in conversation