BookmarkSubscribeRSS Feed
Lapis Lazuli | Level 10



I am trying to launch the SAS environment manager and I get connection refused. I see the SAS environment manager is running. Could you point me to what else I can check and resolve this?


Note : Have anonymized the server name. 


[sasinstaller@sascore01 bin]$ ./ status
HQ Agent is running (PID:25522).
Current agent bundle: agent-5.8.0
Server IP address: sasmd.abcd.local
Server port: 7081
Using new transport; unidirectional=true
Agent listen port: 2145


The agent logs shows the below.


21-02-2018 15:38:47,404 EST INFO [PluginStatusSender] [AgentDaemon@771] Sending plugin status to server
21-02-2018 15:38:47,410 EST WARN [PluginStatusSender] [AgentDaemon@776] could not send plugin status to server, will retry: org.hyperic.hq.bizapp.client.AgentCallbackClientException: Unable to contact server @ http://sasmd.abcd.local:7081/lather: org.apache.http.conn.HttpHostConnectException: Connection to http://sasmd.abcd.local:7081 refused
21-02-2018 15:38:48,168 EST INFO [Poller Client] [PollerClientImpl$PollingRunnable@274] Exception while polling: java.lang.NoClassDefFoundError: Could not initialize class org.jboss.remoting.transporter.InternalTransporterServices
java.lang.NoClassDefFoundError: Could not initialize class org.jboss.remoting.transporter.InternalTransporterServices
at org.jboss.remoting.transporter.TransporterClient.findAlternativeTarget(
at org.jboss.remoting.transporter.TransporterClient.invoke(
at com.sun.proxy.$Proxy15.retrieveRequests(Unknown Source)
at com.hyperic.hq.transport.PollerClientImpl$PollingRunnable.doPolling(
at com.hyperic.hq.transport.PollerClientImpl$

SAS Employee

That certainly doesnt appear to be behaving as it should. This is something to contact your local technical support team about.

Be sure to let technical support know you have a thread on the communities site too.

Hopefully once the cause is found and the issue is resolved we could get an update posted here with what the cause was and how it was resolved.

Lapis Lazuli | Level 10
certainly! Will post the solution once it is resolved
SAS Employee

A good starting place to debug this issue is to ping sasmd.abcd.local on port 7081 outside of SAS to make sure it's open and accessible to incoming requests. If you can't ping that port, you'll need to open it up on the server. Take a look at the SAS® 9.4 Intelligence Platform: Installation and Configuration Guide > Setting Up Users, Groups, and... to make sure that you have set up the ports on the server as outlined.


A few other troubleshooting steps to start with:

  • Environment Manager is configured on port 7080 by default so if you did not perform the install, make sure you are getting the URL for Environment Manager from sas-config/Lev1/Documents/Instructions.html to confirm that you are connecting on the correct port.
  • Make sure that the Environment Manager server is running as well as the agent. Both of these services must be started with the SAS installer account on Linux deployments. 

If you can ping the port and all the services are running as expected, then open a ticket to technical support to request assistance. 

Lapis Lazuli | Level 10

Thanks Shayne for the response. I am able to ping sasmd.abcd.local on port 7081 and see the server and agent running. I shall open this with tech support and see what they come back with. 

Amethyst | Level 16

Hello @RupaJ,


I think this is a case of either of those situations:


- a corrupted agent cached data

- network issues.


For the first one, you can check instructions at . Stop the agent (, delete or rename the data folder and restart the agent.

  1. Stop the SAS Environment Manager agent by submitting the following at a command prompt:
    SAS-configuration-directory/Lev1/Web/SASEnvironmentManager/agent-5.0.0-EE/bin/hq-agent.ext stop

    In this case, ext represents the extension of the file based on your operating environment (Windows: hq-agent.bat / UNIX:

  2. Delete the SAS-configuration-directory/Lev1/Web/SASEnvironmentManager/agent-5.0.0-EE/data directory or rename it to something similar to data_old.
  3. Delete the agent.encrypt.lock file from the system temporary directory, if one exists.
    • In Windows environments, the temporary directory is C:\Users\user-name\AppData\Local\Temp.
    • In UNIX environments, the temporary directory is /tmp.
  4. Restart the SAS Environment agent by submitting this command at a prompt:
    SAS-configuration-directory/Lev1/Web/SASEnvironmentManager/agent-5.0.0-EE/bin hq-agent.ext start

    In this case, ext represents the extension of the file based on your operating environment (Windows: hq-agent.bat / UNIX:

For the later option: do you have more than one network card installed on the machine with the agent, or the machine with the EVM server?


Edit: worst case, perhaps you can un-deploy the EVM agent and re-deploy it again. Not a real bid deal, normally, unless your environment is GRID or one with manual configurations.

Lapis Lazuli | Level 10

JuanS_OCS - Thanks for the response. 


We finally figured the issue after working for over a month with SAS support. The issue was with cache locator not being configured on the midtier. However it was present in the file in the path /opt/sas/config/midtier/Lev2/Web/WebAppServer/SASServer1_1/bin path. After fixing that issue, we tried to restart the web server instances, and had another issue with port 8081 being used by another process. We killed the process and were able to restart the web server instances. That fixed all the webapp issues. 




suga badge.PNGThe SAS Users Group for Administrators (SUGA) is open to all SAS administrators and architects who install, update, manage or maintain a SAS deployment. 

Join SUGA 

CLI in SAS Viya

Learn how to install the SAS Viya CLI and a few commands you may find useful in this video by SAS’ Darrell Barton.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 6 replies
  • 4 in conversation