BookmarkSubscribeRSS Feed
🔒 This topic is solved and locked. Need further help from the community? Please sign in and ask a new question.
S_S
Obsidian | Level 7 S_S
Obsidian | Level 7

Hi,

 

I encountered error on rabbit cluster setup (see deployment.log below). 

I would appreciate any help or pointer on how to resolve the error.

 

"msg": "non-zero return code",
"rc": 3,
"start": "2018-10-13 00:50:43.602535",
"stderr": "",
"stderr_lines": [],
"stdout": "Sat Oct 13 00:50:43 +08 2018 setup_rabbit_cluster *************\nSat Oct 13 00:50:44 +08 2018 setup_rabbit_cluster Beginning SAS RabbitMQ clustering setup\nSat Oct 13 00:50:46 +08 2018 (debug) setup_rabbit_cluster SSL is true\nSat Oct 13 00:50:46 +08 2018 (debug) setup_rabbit_cluster CHECK_PORT is 5671\nSat Oct 13 00:50:46 +08 2018 (debug) setup_rabbit_cluster First host in list is SASVIYA34\nSat Oct 13 00:50:46 +08 2018 (debug) setup_rabbit_cluster First host shortname is SASVIYA34\nSat Oct 13 00:50:46 +08 2018 (debug) setup_rabbit_cluster Primary Host is SASVIYA34\nSat Oct 13 00:50:46 +08 2018 (debug) setup_rabbit_cluster Primary Short Host is SASVIYA34\nSat Oct 13 00:50:46 +08 2018 (debug) setup_rabbit_cluster My Host is SASVIYA34\nSat Oct 13 00:50:46 +08 2018 (debug) setup_rabbit_cluster I am the primary host\nSat Oct 13 00:50:46 +08 2018 setup_rabbit_cluster Copy generated Erlang shared secret to Rabbit.\nSat Oct 13 00:50:57 +08 2018 setup_rabbit_cluster Copying generated Erlang shared secret to Rabbit.\nSat Oct 13 00:50:57 +08 2018 setup_rabbit_cluster Starting sas-viya-rabbitmq-server-default\nSat Oct 13 00:51:41 +08 2018 setup_rabbit_cluster The RabbitMQ service sas-viya-rabbitmq-server-default could not be started.\nSat Oct 13 00:51:41 +08 2018 setup_rabbit_cluster Returned status was 1\nSat Oct 13 00:51:41 +08 2018 setup_rabbit_cluster Setup failed. Beware of independent Rabbit hosts running with different shared secrets.",
"stdout_lines": [
"Sat Oct 13 00:50:43 +08 2018 setup_rabbit_cluster *************",
"Sat Oct 13 00:50:44 +08 2018 setup_rabbit_cluster Beginning SAS RabbitMQ clustering setup",
"Sat Oct 13 00:50:46 +08 2018 (debug) setup_rabbit_cluster SSL is true",
"Sat Oct 13 00:50:46 +08 2018 (debug) setup_rabbit_cluster CHECK_PORT is 5671",
"Sat Oct 13 00:50:46 +08 2018 (debug) setup_rabbit_cluster First host in list is SASVIYA34",
"Sat Oct 13 00:50:46 +08 2018 (debug) setup_rabbit_cluster First host shortname is SASVIYA34",
"Sat Oct 13 00:50:46 +08 2018 (debug) setup_rabbit_cluster Primary Host is SASVIYA34",
"Sat Oct 13 00:50:46 +08 2018 (debug) setup_rabbit_cluster Primary Short Host is SASVIYA34",
"Sat Oct 13 00:50:46 +08 2018 (debug) setup_rabbit_cluster My Host is SASVIYA34",
"Sat Oct 13 00:50:46 +08 2018 (debug) setup_rabbit_cluster I am the primary host",
"Sat Oct 13 00:50:46 +08 2018 setup_rabbit_cluster Copy generated Erlang shared secret to Rabbit.",
"Sat Oct 13 00:50:57 +08 2018 setup_rabbit_cluster Copying generated Erlang shared secret to Rabbit.",
"Sat Oct 13 00:50:57 +08 2018 setup_rabbit_cluster Starting sas-viya-rabbitmq-server-default",
"Sat Oct 13 00:51:41 +08 2018 setup_rabbit_cluster The RabbitMQ service sas-viya-rabbitmq-server-default could not be started.",
"Sat Oct 13 00:51:41 +08 2018 setup_rabbit_cluster Returned status was 1",
"Sat Oct 13 00:51:41 +08 2018 setup_rabbit_cluster Setup failed. Beware of independent Rabbit hosts running with different shared secrets."
]
}
2018-10-13 00:51:41,397 p=5697 u=root | PLAY RECAP **************************************************************************************************
2018-10-13 00:51:41,397 p=5697 u=root | deployTarget : ok=328 changed=154 unreachable=0 failed=1
2018-10-13 00:51:41,397 p=5697 u=root | localhost : ok=14 changed=1 unreachable=0 failed=0

 

Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
JuanS_OCS
Amethyst | Level 16
Hi there,

I suggest to stop all SAS Viya services, to run “ps-ef | grep sas”, to kill any process that is still running, to remove all the Viya installationand, check again ps, then attempt a fresh new reinstall.

View solution in original post

4 REPLIES 4
nhvdwalt
Barite | Level 11

Hi @S_S

 

Check that:

1.) In /etct/hostname you only have the hostname of the server defined e.g. myhost

2.) In /etc/hosts that you have the format <IP> <FQDN> <hostname> e.g. 1.2.3.4 myhost.mycompany myhost

 

Once this is in place, restart the networking service just to be sure and issue the below commands. They should respond with the correct info:

 

hostname

hostname -s

hostname -f

 

S_S
Obsidian | Level 7 S_S
Obsidian | Level 7

Hi,

 

Thanks for the pointer.

 

I have validated both /etc/hostname and /etc/hosts and the output for hostname is as follows.

 

[root@SASVIYA34 sas_viya_playbook]# hostname
SASVIYA34
[root@SASVIYA34 sas_viya_playbook]# hostname -s
SASVIYA34
[root@SASVIYA34 sas_viya_playbook]# hostname -f
SASVIYA34.NDBLAB.local

 

But I am still getting the same error:

  "Wed Oct 17 10:18:53 +08 2018 setup_rabbit_cluster Beginning SAS RabbitMQ clustering setup",
"Wed Oct 17 10:18:54 +08 2018 (debug) setup_rabbit_cluster SSL is true",
"Wed Oct 17 10:18:54 +08 2018 (debug) setup_rabbit_cluster CHECK_PORT is 5671",
"Wed Oct 17 10:18:54 +08 2018 (debug) setup_rabbit_cluster First host in list is SASVIYA34.NDBLAB.local",
"Wed Oct 17 10:18:54 +08 2018 (debug) setup_rabbit_cluster First host shortname is SASVIYA34",
"Wed Oct 17 10:18:54 +08 2018 (debug) setup_rabbit_cluster Primary Host is SASVIYA34.NDBLAB.local",
"Wed Oct 17 10:18:54 +08 2018 (debug) setup_rabbit_cluster Primary Short Host is SASVIYA34",
"Wed Oct 17 10:18:54 +08 2018 (debug) setup_rabbit_cluster My Host is SASVIYA34.NDBLAB.local",
"Wed Oct 17 10:18:54 +08 2018 (debug) setup_rabbit_cluster I am the primary host",
"Wed Oct 17 10:18:54 +08 2018 setup_rabbit_cluster Copy generated Erlang shared secret to Rabbit.",
"Wed Oct 17 10:19:00 +08 2018 setup_rabbit_cluster Copying generated Erlang shared secret to Rabbit.",
"Wed Oct 17 10:19:00 +08 2018 setup_rabbit_cluster Starting sas-viya-rabbitmq-server-default",
"Wed Oct 17 10:19:22 +08 2018 setup_rabbit_cluster The RabbitMQ service sas-viya-rabbitmq-server-default could not be started.",
"Wed Oct 17 10:19:22 +08 2018 setup_rabbit_cluster Returned status was 1",

"Wed Oct 17 10:19:22 +08 2018 setup_rabbit_cluster Setup failed. Beware of independent Rabbit hosts running with different shared secrets."
]
}

PLAY RECAP *********************************************************************
deployTarget : ok=328 changed=151 unreachable=0 failed=1
localhost : ok=14 changed=1 unreachable=0 failed=0

 

Regards,

Yong Chuan.

JuanS_OCS
Amethyst | Level 16
Hi there,

I suggest to stop all SAS Viya services, to run “ps-ef | grep sas”, to kill any process that is still running, to remove all the Viya installationand, check again ps, then attempt a fresh new reinstall.
Martin_Kolberg
Obsidian | Level 7

Hi,

 

I just searched inside support.sas.com and found below suggestion:

https://documentation.sas.com/?docsetId=dplyml0phy0lax&docsetTarget=n0elenlrnmleikn1tfg9es3y1xd4.htm...

 

Setup failed. Beware of independent Rabbit hosts running with different shared secrets

Explanation

Your deployment is using a symbolic link, and there is a symbolic link issue in Erlang 20.2.2. This issue has been fixed in Erlang 20.3.4.

Resolution

  1. Edit the rabbitmq-env file in the /opt/sas/viya/home/lib/rabbitmq-server/sbin/ directory.
  2. Search for RABBITMQ_HOME and set the value to the path of the RabbitMQ home directory. Here is an example:
    RABBITMQ_HOME=/opt/sas/viya/home/lib/rabbitmq-server

 

 

Hope it helps

Bye

Martin

suga badge.PNGThe SAS Users Group for Administrators (SUGA) is open to all SAS administrators and architects who install, update, manage or maintain a SAS deployment. 

Join SUGA 

Get Started with SAS Information Catalog in SAS Viya

SAS technical trainer Erin Winters shows you how to explore assets, create new data discovery agents, schedule data discovery agents, and much more.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 4 replies
  • 3400 views
  • 4 likes
  • 4 in conversation