BookmarkSubscribeRSS Feed
Madhan_cog1
Quartz | Level 8

Hi All,

 

Hi Team,

 

We have SAS Grid 9.4m7 version deployed in Redhat8.1 and the topology is 1 control 2 compute , 3 metadata and 2 Midtier.

 

SAS Studio is not working and we are getting the below issue

 

Madhan_cog1_0-1658848608073.png

 

 

We followed the below steps to see if we can fix the issue but it still doesn’t work.

 

  1. Stop the SAS Web Application Servers on the middle tier servers using 'sas.servers stop'
  2. Execute the following commands to check for orphaned processes:
  •          netstat -tlp | grep 41415
  •          netstat -tlp | grep 61616
  •          netstat -tlp | grep 8080
  •          netstat -tlp | grep 7980
  •          ps -ef | grep gemfire
  •          ps -ef | grep -i SASPrivateJavaRuntimeEnvironment
  1. Kill any processes returned by the above commands.
  1.                   Delete (or move/archive) the contents of the following directories:
  •          NOTE: Please be sure to delete the CONTENTS of the following directories, and not the directories themselves.
  •          NOTE: The X and Y in "SASServerX_Y" represent the different servers you may have (i.e. "SASServer1_1").
  •          <SAS_CONFIG>/Lev#/Web/WebAppServer/SASServerX_Y/logs/*
  •          <SAS_CONFIG>/Lev#/Web/WebAppServer/SASServerX_Y/work/*  (these temporary files do not need to be backed up)
  •          <SAS_CONFIG>/Lev#/Web/WebAppServer/SASServerX_Y/temp/*  (these temporary files do not need to be backed up)
  •          <SAS_CONFIG>/Lev#/Web/WebServer/logs/*
  •          <SAS_CONFIG>/Lev#/Web/gemfire/instances/ins_41415/*.log
  •          <SAS_CONFIG>/Lev#/Web/gemfire/instances/ins_41415/*.dat
  •          <SAS_CONFIG>/Lev#/Web/gemfire/instances/ins_41415/.locator
  •          <SAS_CONFIG>/Lev#/Web/activemq/data/*
  •          <SAS_CONFIG>/Lev#/Web/Logs/SASServerX_Y/*
  1. Start the SAS Web Application Servers on the middle tier servers using 'sas.servers start'

 

Kindly help us to resolve the issue.

6 REPLIES 6
gwootton
SAS Super FREQ
A 404 suggests that the SAS Studio web application is not running. Often that's on SASServer2_1. Do you see any errors in <SAS_CONFIG>/Levn/Web/WebAppServer/SASServer2_1/logs/server.log indicating the application could not start?
--
Greg Wootton | Principal Systems Technical Support Engineer
Madhan_cog1
Quartz | Level 8

Hi Greg,

 

Thanks for the quick response.

 

I could see the below in the log.

 

2022-07-25 14:23:22,890 ERROR (localhost-startStop-1) [org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/SASEnvironmentMgrMidTier]] Error configuring application listener of class [com.sas.svcs.webapp.servlet.springframework.DefaultContextLoaderListener]
java.lang.ClassNotFoundException: com.sas.svcs.webapp.servlet.springframework.DefaultContextLoaderListener
at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(WebappClassLoaderBase.java:1358)
at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(WebappClassLoaderBase.java:1180)
at org.apache.catalina.core.DefaultInstanceManager.loadClass(DefaultInstanceManager.java:546)
at org.apache.catalina.core.DefaultInstanceManager.loadClassMaybePrivileged(DefaultInstanceManager.java:527)
at org.apache.catalina.core.DefaultInstanceManager.newInstance(DefaultInstanceManager.java:150)
at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4623)
at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5167)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:183)
at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:743)
at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:719)
at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:705)
at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:614)
at org.apache.catalina.startup.HostConfig$DeployDescriptor.run(HostConfig.java:1823)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)
2022-07-25 14:23:22,890 ERROR (localhost-startStop-1) [org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/SASEnvironmentMgrMidTier]] Skipped installing application listeners due to previous error(s)
2022-07-25 14:23:22,890 ERROR (localhost-startStop-1) [org.apache.catalina.core.StandardContext] One or more listeners failed to start. Full details will be found in the appropriate container log file
2022-07-25 14:23:22,891 ERROR (localhost-startStop-1) [org.apache.catalina.core.StandardContext] Context [/SASEnvironmentMgrMidTier] startup failed due to previous errors
2022-07-25 14:23:22,895 INFO (localhost-startStop-1) [org.apache.catalina.startup.HostConfig] Deployment of deployment descriptor [/sas/sasconf/Lev1/Web/WebAppServer/SASServer2_1/conf/Catalina/localhost/SASEnvironmentMgrMidTier.xml] has finished in [4,075] ms
2022-07-25 14:23:22,905 INFO (localhost-startStop-4) [org.apache.catalina.startup.HostConfig] Deploying web application directory [/sas/sasconf/Lev1/Web/WebAppServer/SASServer2_1/webapps/ROOT]
2022-07-25 14:23:24,316 INFO (localhost-startStop-4) [org.apache.catalina.startup.HostConfig] Deployment of web application directory [/sas/sasconf/Lev1/Web/WebAppServer/SASServer2_1/webapps/ROOT] has finished in [1,411] ms
2022-07-25 14:23:24,358 INFO (main) [org.apache.tomcat.util.net.NioSelectorPool] Using a shared selector for servlet write/read
2022-07-25 14:23:24,364 INFO (main) [org.apache.catalina.startup.Catalina] Server startup in 5921 ms

 

Thanks,

Madhan M

gwootton
SAS Super FREQ
That error is not for /SASStudio but for /SASEnvironmentMgrMidTier. Do you see a similar error for SASStudio? Sounds like an issue with your libraries, so you may want to contact SAS Technical Support.
--
Greg Wootton | Principal Systems Technical Support Engineer
Madhan_cog1
Quartz | Level 8

Hi Greg,

 

I contacted SAS Tech support already but yet to get a response .

 

Would you like me to share any logs for you to help me out in sorting this issue.

 

Kindly let me know if you can assist me on this .

 

Thanks,

Madhan M

gwootton
SAS Super FREQ
You should probably wait for a response from SAS Technical Support.

Assuming you are getting the same failure for SASStudio as you are for SASEnvironmentMgrMidTier in that server.log file:

java.lang.ClassNotFoundException: com.sas.svcs.webapp.servlet.springframework.DefaultContextLoaderListener

This reads to me that your java classpath is missing one or more JARs, so you could try rebuilding and redeploying the problematic web application(s). You could also check the setenv.sh file for that web application server (SASServer2_1/bin/setenv.sh) to make sure the classpath hasn't been changed there.

Administer SAS Web Applications
https://go.documentation.sas.com/doc/en/bicdc/9.4/bimtag/p01ad6do1p5uonn1rki80yy95a23.htm

If the error is different for SAS Studio, then the fix might be different as well.
--
Greg Wootton | Principal Systems Technical Support Engineer
Sajid01
Meteorite | Level 14

Did you to check server status on the mid tier (sas.server status)  on the midtier?
You can also ping from the desktop to server.
Apparently, the server is not running. 
if you have a firewall /reverse proxy please involve the network team.

suga badge.PNGThe SAS Users Group for Administrators (SUGA) is open to all SAS administrators and architects who install, update, manage or maintain a SAS deployment. 

Join SUGA 

Get Started with SAS Information Catalog in SAS Viya

SAS technical trainer Erin Winters shows you how to explore assets, create new data discovery agents, schedule data discovery agents, and much more.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 6 replies
  • 2225 views
  • 0 likes
  • 3 in conversation