BookmarkSubscribeRSS Feed
🔒 This topic is solved and locked. Need further help from the community? Please sign in and ask a new question.

Hi All,

 

Please advise how to hold all jobs in scheduler manager (SMC) with sasadm user.

 

 

Jobs are scheduled with other users.

1 ACCEPTED SOLUTION

Accepted Solutions
JuanS_OCS
Amethyst | Level 16

Hello @sewa_bal_gmail_com,

 

as @LinusH said, please do not confuse the Schedule Manager as your real job scheduler, because it is not, only an interface.

 

Your best option is to go your your real scheduler and disable those jobs.

 

  • If you are on Linux, your schedulers might be cron, at or Flow Manager.
  • If you are on Windows, your schedulers will be the Windows Task Manager or Flow Manager.

Hope it helps.

 

Juan

View solution in original post

5 REPLIES 5
LinusH
Tourmaline | Level 20

We need a bit more info.

- What scheduler are you using? Platform LSF, crontab/Windows task

- What do you mean by hold? Like stop new flows/jobs from starting?

- SAS version

Data never sleeps
sewa_bal_gmail_com
Quartz | Level 8

During the upgrade, we need to stop all ongoing process and once update completed then we will start all the schedule jobs.

 

We are using schedule manager which is available under sas management console.

 

 

Version sas9.4 M4

 

 

SASKiwi
PROC Star

If you have just a few jobs you can just right click on the job in SMC and select Unschedule Flow. It is quick and easy to do. Re-scheduling after an upgrade is quick and easy too.

LinusH
Tourmaline | Level 20
Well, the name Schedeule Manager might be somewhat confusing, it's not a scheduler.
You use it to define jobs and flows, and then deploys those to the external Scheduler of choice. The actual day to day execution and monitoring takes place in the scheduler tool.
Possible you could unregister your flows from within SMC, and deploy the flows again when they shouldn't be on his any more. But to me this sounds awkward and dangerous. So for at least Platform LSF it's preferable to have this managed in their interface.
Data never sleeps
JuanS_OCS
Amethyst | Level 16

Hello @sewa_bal_gmail_com,

 

as @LinusH said, please do not confuse the Schedule Manager as your real job scheduler, because it is not, only an interface.

 

Your best option is to go your your real scheduler and disable those jobs.

 

  • If you are on Linux, your schedulers might be cron, at or Flow Manager.
  • If you are on Windows, your schedulers will be the Windows Task Manager or Flow Manager.

Hope it helps.

 

Juan

suga badge.PNGThe SAS Users Group for Administrators (SUGA) is open to all SAS administrators and architects who install, update, manage or maintain a SAS deployment. 

Join SUGA 

CLI in SAS Viya

Learn how to install the SAS Viya CLI and a few commands you may find useful in this video by SAS’ Darrell Barton.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 5 replies
  • 1690 views
  • 2 likes
  • 4 in conversation