BookmarkSubscribeRSS Feed
☑ This topic is solved. Need further help from the community? Please sign in and ask a new question.
MariaD
Barite | Level 11

Hi Folks, 

 

We have  SAS 9.4 M7 grid environment on Linux running. Recently we bought SAS Access to Big Query module. We tried to add it to our existing environment, but after installing it, SAS Metadata Server stopped working, 

 

Basically, we installed first using the -nosasupdate parameter and selecting only SAS Access to Big Query. Even using it, the installation update/executes 230 steps. After the installation was completed, we started the SAS services. All services starting correctly but we can only connect on MetadataServer with sasadm@saspw account. If we use any other account, nothing happens, no messages in any log (even with trace enabled). 

 

After the initial tentative, we restored the environment. The second time, we removed all the hotfixes available in the hot_fixes folder inside the depot. Again, we installed using -nosasupdate parameter and selecting only SAS Access to BQ. Now, the installation executes 109 steps. Again, everything finished ok and the SAS services started correctly but the same behavior occurred. 

 

Now, we restored the environment. Any idea on how to proceed? 

 

Regards, 

1 ACCEPTED SOLUTION

Accepted Solutions
MariaD
Barite | Level 11

Thanks @eddieleung305 . We finally found the error. I don't know why but after the installation the files sasauth, sasperm and elssr inside ..SASFoundation/utilities/bin changed from root owner to sas owner. So, we run the !SASROOT/utilities/bin/setuid.sh and now all it's working fine. 

 

Regards, 

View solution in original post

2 REPLIES 2
eddieleung305
Obsidian | Level 7

I think this is a tricky question. Adding an additional SAS/ACCESS engine will not cause issues related to the Metadata Server.

However, you mentioned that your existing system is in SAS9.4M7. Have you checked if your new depot is in M7 or M8? If so then it may be related to JRE version changes since M8. 

Please check your new depot shipment version to confirm it is in M7 or M8. You also can find related ordersummary.html in the depot's install_doc directory

MariaD
Barite | Level 11

Thanks @eddieleung305 . We finally found the error. I don't know why but after the installation the files sasauth, sasperm and elssr inside ..SASFoundation/utilities/bin changed from root owner to sas owner. So, we run the !SASROOT/utilities/bin/setuid.sh and now all it's working fine. 

 

Regards, 

suga badge.PNGThe SAS Users Group for Administrators (SUGA) is open to all SAS administrators and architects who install, update, manage or maintain a SAS deployment. 

Join SUGA 

CLI in SAS Viya

Learn how to install the SAS Viya CLI and a few commands you may find useful in this video by SAS’ Darrell Barton.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 2 replies
  • 359 views
  • 0 likes
  • 2 in conversation