If you created or loaded the table then I would expect that you also have the permissions to drop or truncate the table.
For tables and data that you only need within a session I would also only create the table with session scope and not promote it. That will drop the table the moment your session gets terminated.
The error message you shared is about CAS_DISK_CACHE which for example gets used when CAS needs to move data from one node to another.
https://documentation.sas.com/doc/en/pgmsascdc/9.4_3.2/caspg/n09dk3dbd4xlccn18dl6i9be29hs.htm
This disk space is shared by all CAS processes and though it's not necessarily what you have been doing that caused the issue.
With Viya things improve quickly. Please always share the release you're working with.