BookmarkSubscribeRSS Feed
☑ This topic is solved. Need further help from the community? Please sign in and ask a new question.
sskt
Obsidian | Level 7

いつもお世話になっております。

 

proc report内に

call define(_col_, 'style', "style=[leftmargin=0.25in]");

と書いていると、odsでrtf出力したときにはインデントされますが、
odsでxlsxで出力した際にインデントされなくなってしまいます。

どのように対処すればよろしいでしょうか。


よろしくお願い致します。

1 ACCEPTED SOLUTION

Accepted Solutions
Ksharp
Super User
ods excel file='c:\temp\x.xlsx';
proc report data=sashelp.class nowd;
compute name;
call define(_col_, 'style', "style=[indent=0.25in]");
endcomp;
run;
ods excel close;

View solution in original post

2 REPLIES 2
Ksharp
Super User
ods excel file='c:\temp\x.xlsx';
proc report data=sashelp.class nowd;
compute name;
call define(_col_, 'style', "style=[indent=0.25in]");
endcomp;
run;
ods excel close;
sskt
Obsidian | Level 7

I got the output I wanted by setting it to indent instead of leftmergin. Thank you very much.

 

leftmerginではなく、indentにするとこで私の望む出力が得られました。ありがとうございました。

sas-innovate-2024.png

Don't miss out on SAS Innovate - Register now for the FREE Livestream!

Can't make it to Vegas? No problem! Watch our general sessions LIVE or on-demand starting April 17th. Hear from SAS execs, best-selling author Adam Grant, Hot Ones host Sean Evans, top tech journalist Kara Swisher, AI expert Cassie Kozyrkov, and the mind-blowing dance crew iLuminate! Plus, get access to over 20 breakout sessions.

 

Register now!

Discussion stats
  • 2 replies
  • 673 views
  • 1 like
  • 2 in conversation