BookmarkSubscribeRSS Feed
huikeng_sas
SAS Employee
Hi,

I have encountered the following problem with EG4.2 :

- I registered a library and some tables in SMC. However, when I navigate to the folder within EG, I am not able to see those tables that I have registered.
- I am granted RM, WM,WMM,CM and R to the folder
- I am able to access the registered library and tables via the Server list.
- When I go to Tools>SAS EG Explorer, I am able to see the registered library in the folder, but not the tables.
- I am able to see the library and tables in the folder within DI Studio

Is there any options which I need to provide in order for the tables to appear in the EG folders?

Thanks!
8 REPLIES 8
RichardH_sas
SAS Employee
Hmm, seeing the tables in the server list but not in the SAS folder where they were registered is kind of puzzling. A couple things to try (in order of simplicity):

1. Are the registered tables and the library definition stored in the same SAS folder? They don't have to be, but you can get into some complex security scenarios if they aren't.

2. From SAS Management Console (SMC), use the data library manager plug-in to check the properties for the library. In particular, see if the library is pre-assigned (under Options / Advanced Options) and see if the there are any extended attributes (under Extended Attributes) and what those name/value pairs show.

3. If you are an unrestricted user, from SMC check the specific permissions of your EG user on the tables and library definition. You can do so by right-clicking on the problem table in SMC, selecting Properties, going to the Authorization tab, clicking the Advanced button, then searching for the relevant user on that second tab. See what effective permissions that user has on the registered table and then repeat for the library definition.

Hope this helps... you're also welcome to get in touch with tech support (http://support.sas.com/techsup/contact/)
deleted_user
Not applicable
Richard,

I'm having the same problem. Library definition is in the same SAS folder as the tables; the library is pre-assigned; there are no extended attributes; the permissions for the tables and the library definition for the EG user seem to permit read access.

Thanks,
Steve Whipple
twocanbazza
Quartz | Level 8
Hi Guys...

This may be a Red Herring, but what roles are associated to your user ID's?

Barry
deleted_user
Not applicable
Hi Barry,

Originally the only role associated with the user was Metadata Server: Unrestricted. I've tried adding the four EG roles: Advanced, Analysis, OLAP, and Programming, but that doesn't seem to help. Thanks for taking a look.

Regards,
Steve
Patrick
Opal | Level 21
Just a thought:
As this is a new pre-assigned library could it be that the object spawner has to be restarted?
deleted_user
Not applicable
Hi Patrick,

Thanks for your suggestion. Before I tried it I got it working by assigning the library to the SAS Application (SASApp) server. In management console select the library in Data Library Manager; right click and select properties; go to the Assign tab and move SASApp to the selected server box. The datasets will then appear in the SAS Folders in EG.

Regards,
Steve
RichardH_sas
SAS Employee
If the library is pre-assigned and there are no extended attributes, the server list in EG should be showing you all the physical tables for that library as long as the appropriate user has ReadMetadata for that library definition. In EG, when you select View / Server List and expand down, do you see the library in question?

A few other things to look at in SAS Management Console. For this, right-click on the library definition and select Properties.
1. On the Assign tab, make sure an application server is selected that the user in question can access. That will be displayed on the right under Assigned Servers. Now that I think about it, the original post may have had this problem... since without an Assigned Server the library would not show up in EG but would show up in DI Studio.
2. On the Options tab, jot down the Libref value shown.

Using the libref from #2 above (e.g., wombat), now go into EG and submit the following code.

libname wombat list;

(where you replace wombat with whatever your libref is)

Make sure this code is submitted on the appropriate server (there's a select server button at the top of the program in EG if you aren't sure). Then look in the log to see if the value of Engine for the library lists META or something else. If the value is META, there may be an autoexec file which is forcing assignment with the Metadata Libname Engine. That's not a bad thing in and of itself, but some of the consequences could be why you're not getting the behavior you expect for the library.
RichardH_sas
SAS Employee
Took too long to respond... you solved it yourself. Excellent! 🙂

sas-innovate-2024.png

Available on demand!

Missed SAS Innovate Las Vegas? Watch all the action for free! View the keynotes, general sessions and 22 breakouts on demand.

 

Register now!

SAS Enterprise Guide vs. SAS Studio

What’s the difference between SAS Enterprise Guide and SAS Studio? How are they similar? Just ask SAS’ Danny Modlin.

Find more tutorials on the SAS Users YouTube channel.

Click image to register for webinarClick image to register for webinar

Classroom Training Available!

Select SAS Training centers are offering in-person courses. View upcoming courses for:

View all other training opportunities.

Discussion stats
  • 8 replies
  • 2364 views
  • 0 likes
  • 5 in conversation