BookmarkSubscribeRSS Feed
☑ This topic is solved. Need further help from the community? Please sign in and ask a new question.
Obsidian | Level 7

Hello SAS Community,


I have some datasets with date columns, however, some of my blank cells seem to be auto-filling with a " ."


It presents an issue when I export my data into Excel and the columns are interpreted as character instead of date.


It would be great if blank cells were left blank. Is there a simple way to turn off this future? Or do I have to add additional lines of code to replace "." with " " 


Any help is much appreciated!


Accepted Solutions
Diamond | Level 26

Try setting the SAS option as follows


options missing=' ';
Paige Miller

View solution in original post

Diamond | Level 26

Try setting the SAS option as follows


options missing=' ';
Paige Miller
Super User

You might try setting  (that is a single space between quotes)

options missing=' ';

prior to use.


Though that may depend on just how you export data to excel.


There is ALWAYS something in the data set. The option sets a single character character to display by default when a value is missing. You can basically use any single character you would like. OR create a custom format and use the format to display even more interesting results...


There is no "auto-filling" going on.


Don't miss out on SAS Innovate - Register now for the FREE Livestream!

Can't make it to Vegas? No problem! Watch our general sessions LIVE or on-demand starting April 17th. Hear from SAS execs, best-selling author Adam Grant, Hot Ones host Sean Evans, top tech journalist Kara Swisher, AI expert Cassie Kozyrkov, and the mind-blowing dance crew iLuminate! Plus, get access to over 20 breakout sessions.


Register now!

Mastering the WHERE Clause in PROC SQL

SAS' Charu Shankar shares her PROC SQL expertise by showing you how to master the WHERE clause using real winter weather data.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 2 replies
  • 3 in conversation