macros and %include problem

Reply
N/A
Posts: 0

macros and %include problem

Hi everyone,

I am facing a problem with a macro code. I wrote a macro and supplied positional parameters to it. I supply the logic and the description and when i run the program it runs fine, but when I use a %include statement to reference my source code along with other codes it gives a warning in log saying TRUNCATED record. and stops the program there.
rest of the code shows the symbolgen in log but the program dosen't run.

Can you please help and tell me what is happening here.
I've tried everything i could.

Thanks!

April
SAS Super FREQ
Posts: 8,645

Re: macros and %include problem

Hi:
Perhaps you are experiencing one of these problems:
http://support.sas.com/kb/11/447.html
http://support.sas.com/kb/4/448.html
http://support.sas.com/kb/8/328.html

You might consider contacting Tech Support for more help with this issue.
cynthia
N/A
Posts: 0

Re: macros and %include problem

Hi Cynthia,

Thanks a lot for the help. I spent hours on the problem but couldn't figure out. I am surely going to use it and see if it runs smoothly.

Thanks again.

April.
N/A
Posts: 0

Re: macros and %include problem

Hi

I tried to use the options to resolve the macros problem but it still dosent run
and gives me a warning of truncated records in log when I use a %include.

If there is any thing that I can try Please let me know.

Regards,
April
SAS Super FREQ
Posts: 8,645

Re: macros and %include problem

Hi:
This is really one of those times when Tech Support is your best resource. To send a question or open a track with Tech Support, go to http://support.sas.com/ and in the left-hand navigation pane, click on the link entitled "Submit a Problem".

cynthia
N/A
Posts: 0

Re: macros and %include problem

Thanks a lot ....
Post a Question
Discussion Stats
  • 5 replies
  • 445 views
  • 0 likes
  • 2 in conversation