GetMetadataObjects does not return objects

Reply
Not applicable
Posts: 0

GetMetadataObjects does not return objects

Hi guys.
I use GetMetadataObjects to return objects of PhysicalTable type:

%macro metatest();
%let objects =;
%let rc = GetMetadataObjects("$METAREPOSITORY", "PhysicalTable", objects, "SAS", 1, "");

%if rc LT 1 %then %do;
%put "No objects found.";

%end;
%else %put &objects;

%mend;

/* Test CODE */
%metatest;

but it outputs an empty objects variable (no errors) O_o.

Manual says that objects is Returned list of metadata objects. (direction=out)

Help me please.
PS: do not propose using Do request, I need this way.
SAS Super FREQ
Posts: 9,365

Re: GetMetadataObjects does not return objects

Posted in reply to deleted_user
Hi:
This looks like a Bus Intelligence/Metadata Repository question. I'm not sure what it has to do with clinical trials, unless you are using the BI Platform for clinical data.

Your question is probably not going to get responses here or in other forums, since it's so specific and related to the BI Platform. Your best bet for help on this question may be to open a track with Tech Support, as they have the kind of expertise that you need for these techniques.

cynthia
Not applicable
Posts: 0

Re: GetMetadataObjects does not return objects

Posted in reply to Cynthia_sas
Please move my post to most suitable forum
SAS Super FREQ
Posts: 9,365

Re: GetMetadataObjects does not return objects

Posted in reply to deleted_user
Hi:
There really isn't a forum for these kinds of questions, where you are working with the metadata using calls like this.

For help with this particular question, you should open a track with Tech Support.

cynthia
Ask a Question
Discussion stats
  • 3 replies
  • 403 views
  • 0 likes
  • 2 in conversation