Traditional web-based reporting with SAS BI tools

prefilter in sas olap cube report

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 12
Accepted Solution

prefilter in sas olap cube report

I have requirement where I want to add prefilter in the final report but that filter should be hidden from user.

I am using OLAP cube for that report and displaying in WRS through SAS Infomap. Is it possible to add prefilter in SAS OLAP cube as now the option is not available in SAS InfoMap. Any Info available are welcome to share?


Accepted Solutions
Solution
‎03-31-2017 09:38 AM
SAS Super FREQ
Posts: 465

Re: prefilter in sas olap cube report

The Hide from User option for filters in the information map is for use with prefilters. However, you cannot create prefilters for OLAP data. Your only option is to create an MDX expression directly on the cube. This is described in

 

http://support.sas.com/documentation/cdl/en/olapug/69844/HTML/default/viewer.htm#n0kme6xgwhlfoyn1f5m...

View solution in original post


All Replies
SAS Super FREQ
Posts: 465

Re: prefilter in sas olap cube report

Do you need the filter for security reasons? For example, SAS Demo User should be able to see only information for North Carolina. Or do you want to filter results in the report but not allow users to change the filter value?

Occasional Contributor
Posts: 12

Re: prefilter in sas olap cube report

Yes I want to filter results in the report but not allow users to change the filter value and also the filter which I applied should not be visible to the end user while seeing the report.

Super User
Posts: 5,380

Re: prefilter in sas olap cube report

@ashu464810 unfortunately your reply makes nothing to enlighten your requirement.
Ading a filter to the cube itself makes little sense, if that's your take, create a new cube instead.
Data never sleeps
Occasional Contributor
Posts: 12

Re: prefilter in sas olap cube report

@LinusH I understand but I have one doubt we can create filter in Information map studio for Cube Based report but when I am trying to hide the filter from user it is not filtering the data rather I am getting all the recorods from the table. Can you help me with this?

Thnx

SAS Super FREQ
Posts: 465

Re: prefilter in sas olap cube report

To apply the filter you created in the information map in Web Report Studio, you would have to select Section Filters from the Options menu on the Section Data pane on the left, and specifically select the filter. It is not applied automatically. However, information about the filter is displayed if the person viewing the report has the Display Applied Filter preference turned on.

 

You might want to consider MDX permissions on the cube. You can do that via SAS Management Console. See

http://support.sas.com/documentation/cdl/en/olapug/69844/HTML/default/viewer.htm#n0kme6xgwhlfoyn1f5m...

 

Occasional Contributor
Posts: 12

Re: prefilter in sas olap cube report

@Madelyn_SAS My requirement is to filter the data from the column and the filter which I apply should not be visible to all the end user....I know there is option of hide from user  in SAS Information Map studio but when I am trying to set that I am not getting the filtered data also I am not getting pre filter option in Information Map studio when I am using SAS Olap Cube as source in Information Map studio.

Solution
‎03-31-2017 09:38 AM
SAS Super FREQ
Posts: 465

Re: prefilter in sas olap cube report

The Hide from User option for filters in the information map is for use with prefilters. However, you cannot create prefilters for OLAP data. Your only option is to create an MDX expression directly on the cube. This is described in

 

http://support.sas.com/documentation/cdl/en/olapug/69844/HTML/default/viewer.htm#n0kme6xgwhlfoyn1f5m...

Occasional Contributor
Posts: 12

Re: prefilter in sas olap cube report

@Madelyn_SAS Thank you for your Info....Now I have given normal filter for my report

 

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 8 replies
  • 409 views
  • 0 likes
  • 3 in conversation