Traditional web-based reporting with SAS BI tools

Using defined set from a OLAP cube in Information Map Studio/WRS

Reply
New Contributor
Posts: 3

Using defined set from a OLAP cube in Information Map Studio/WRS

Hi,

I've created an OLAP cube and defined three custom sets (e.g. DEFINE SET "[&newcube.].[R6]" as "Tail([Time].[YM].[MONTH].AllMembers ,6)"Smiley Wink. In Enterprise Guide I can see and use these sets as expected, but when I try to add them as new data items in Information Map Studio (4.2) (instructions from e.g. http://www.bi-notes.com/2011/12/sas-olap-cubes-tailing-time-based-data-dynamic-results/ ) using e.g. {[R6]} as the expression and OLAP category as type nothing happens when I press the OK button. The software seems to be working for a while, but never actually exits the define expression window. Pressing "Validate expression" throws an error message about "java.lang.nullpointerException".

Am I doing something wrong, is the error message indicating something wrong with my data? And what would be the correct syntax to add the defined sets using proc infomaps?

Br,

Tor Helge Huse

New Contributor
Posts: 3

Re: Using defined set from a OLAP cube in Information Map Studio/WRS

I'll just answer myself. Today, for no apparent reason to me, everything works. The only difference is that yesterday I was working at home through a VPN connection and today I'm at work and connected directly. Information Map Studio is running on Citrix, so there could be some kind of issue with this and the VPN connection.

Ask a Question
Discussion stats
  • 1 reply
  • 277 views
  • 0 likes
  • 1 in conversation