Traditional web-based reporting with SAS BI tools

SASWebReportStudio4.2_KeyActions.log

Reply
Super Contributor
Posts: 356

SASWebReportStudio4.2_KeyActions.log

Hi,

Part of the event in the key actions log contains

UserID@!*(generatedpassworddomain)*!

Can someone tell me what the "@!*(generatedpassworddomain)*!" is as we are getting a few users with this in their user string in the log, others just have the userid.

WRS4.2 SAS9.2M2

Cheers

Barry
SAS Employee
Posts: 238

Re: SASWebReportStudio4.2_KeyActions.log

Barry,
I was doing some research on this and found some old notes (2005). There is likely a difference in how the users are setup. The domain string cannot be located either from the Metadata or from the user themselves and so the default @!(... string is included. Can you verify whether the users that show this '(generatedpassworddomain)' are defined on the host machine?
You could also review the setups in SAS Management Console User manager. Wonder if the 'Authentication' tab is different for the different users.

There is information on different auth setups documented at:
http://support.sas.com/rnd/itech/doc9/admin_oma/security/grpuserlog_defs.html

Let me know what you find in Mgmt Console.

~ Angela
Super Contributor
Posts: 356

Re: SASWebReportStudio4.2_KeyActions.log

Hi Angela.

The users appear to have the same setup in Metadata, except for the userid of course.

If you are meaning the web server when you say host, no-one is defined directly as a user on that machine, all done as domain users.

The funny thing is on our development machine, I haven't seen this issue. And the setup on the two environments are the same (so I have been told).

Ona side note we are using We are using SSO.

Barry
Super Contributor
Posts: 356

Re: SASWebReportStudio4.2_KeyActions.log

Update.

It appears to be happining with the SSO... however if we log off WRS and then back in typing the credentials it displays the Userid typed in ...
SAS Employee
Posts: 238

Re: SASWebReportStudio4.2_KeyActions.log

If you havent already, I would suggest opening a track with Technical Support. Sounds like a configuration issue with SSO.

~ Angela
Super Contributor
Posts: 356

Re: SASWebReportStudio4.2_KeyActions.log

Way ahead of you, but seems like I get more/better information from here sometimes Smiley Wink...

Will update if any progress made.
Post a Question
Discussion Stats
  • 5 replies
  • 259 views
  • 0 likes
  • 2 in conversation