Traditional web-based reporting with SAS BI tools

Entire header should be in a single row with Image Logo having link

Reply
Occasional Contributor
Posts: 13

Entire header should be in a single row with Image Logo having link

Dear Team, We want to display report with headers having below three in single line. 1-Date (At upper left corner). 2-Title (At Center). 3- image help logo with help link (Upper Right corner). We have created a stored procedure for this purpose, while we are executing in enterprise guide it will display the required output title with three things in single line as below given screen shot for your reference. (Need to decries size of Logo) But when we use that stored procedure in Web Report Studio it gives out put in below manner, -Title is not in single line. - Image Logo is not display on Web Report Studio. We are using below SAS Code for the same. *ProcessBody; %stpbegin; ods escapechar="~"; %let refreshed=%sysfunc(date()); %put &refreshed; Title height=9pt color=black justify=left "Data as of %sysfunc(putn(&refreshed,mmddyy10.))" j=c font=Arial height=12 bold "Summary Report" j=r height=11 link="http:// www.helpportal.com" "~{style[preimage='/apps/usr/HelpIcon2.jpg' ]} " data test; a=' '; run; proc report data=test noheader style(report)=[cellspacing=0 borderwidth=0] style(column)=[borderwidth=0] style(header)=[background=white] ; column a ; run; %stpend; Please provide solution for this. 1-Title in single line. 2-Logo should be display on Web report studio Is there any option need to change or anything else?? System Details SAS Web Report Studio 4.4 M3 I E Version 11.0 Enterprise guide 7.1
Output_EG.jpgOutPut_WRS.jpg
Occasional Contributor
Posts: 13

Re: Entire header should be in a single row with Image Logo having link

We need to Display the entire header should be in a single row on Web Report Studio, with below mentioned conditions . 1- Report header shows left aligned Data as of date in MM/DD/YYYY format. 2- Report header shows center aligned Report title. 3- Report header shows right aligned Help Logo with link for Report. Below code is working in enterprise guide but when We use it on Web report Studio Below the result 1-It doesn't show image/Logo. 2-Entire header is not display in single line. Again I am sharing used code. Please suggest any solution. %stpbegin; ods escapechar="^"; ods html file="/apps/Title2.html" style=sasweb; title j=r height=2 link="http://oagcs-savax04.csnet.gov:10175/wps/portal/ershelp" "^{style[preimage='/apps/usr/Komal/HelpIcon2.jpg' ]} " j=c height=3 "Sales Report" j=l height=2 "Date as of:1/12/2016"; proc report data=Test; run; ods html close; ods listing; %stpend;
Ask a Question
Discussion stats
  • 1 reply
  • 146 views
  • 0 likes
  • 1 in conversation