Traditional web-based reporting with SAS BI tools

Date Format Not getting sorted in SAS OLAP Cube

Reply
Occasional Contributor
Posts: 12

Date Format Not getting sorted in SAS OLAP Cube

Hi, I have a report which is based on OLAP Cube and it is having Time as dimension. When I am trying to sort the Year, Month,Day in descending order only year is getting sorted other  level are coming in random order. For ex- month is coming as Dec Nov Jan Mar Oct etc . Same is the case with Day level. Any workaroud how to resolve the issue.


Cube.png
SAS Super FREQ
Posts: 468

Re: Date Format Not getting sorted in SAS OLAP Cube

There is an option on the Data menu that says "Include Members with Only Missing Values." If this option is unchecked, then I suggest checking it to see if that changes the behavior.

 

 

Occasional Contributor
Posts: 12

Re: Date Format Not getting sorted in SAS OLAP Cube

@Madelyn_SAS Where exactly this  option is available. Can you please give exactly where to look for this option.

SAS Super FREQ
Posts: 468

Re: Date Format Not getting sorted in SAS OLAP Cube

When you are viewing your OLAP report, select the Data menu. I am attaching an image. If this option is not checked, then try checking it to see if it changes the sort behavior.

 

Here are some other notes related to date sorting for OLAP:

 

Other thoughts:

  • Did explicitly sort the Time dimension in the table? You right click on the column header (Year, in your case, I think) to open the menu.
  • When you defined the cube, what sort order did you select. I believe that there are 5
    •ascending unformatted
    •descending unformatted
    •ascending formatted
    •descending formatted
    •data set order

 

 

 


olap_missing_members.jpg
Occasional Contributor
Posts: 12

Re: Date Format Not getting sorted in SAS OLAP Cube

[ Edited ]

I have given year heirarchy as inherited ascending format ,month as inherit ascending format and date when I have given Ascending Formated ,days are coming fine but still the month are not coming in sorted order. I tried to give all the possible format available to the month column level but all in vain....Nothing changed. I also added the option include the missing value as you mentioned but that also not working properly.

Ask a Question
Discussion stats
  • 4 replies
  • 179 views
  • 2 likes
  • 2 in conversation