Exploring, predicting and reporting with SAS Visual Analytics and SAS Visual Statistics

sasv9_local.cgf settings for SAS VA Non Distributed

Reply
Contributor
Posts: 49

sasv9_local.cgf settings for SAS VA Non Distributed

Are there any specific settings to add in sasv9_local.cgf for SAS VA Non Distributed? Some of the settings we added are below but these are typical settings for all SAS applications not just VA. I am curious to know if there are any specific options we can add for SAS VA. 

 


-VALIDVARNAME ANY
-WORK 
-MEMSIZE
-SORTSIZE 
-WORKPERMS 
-UTILLOC 
-FULLSTIMER

 

SAS Super FREQ
Posts: 558

Re: sasv9_local.cgf settings for SAS VA Non Distributed

@Matt,


You need to properly adjust MEMSIZE. With the default value, you won't be able to load more than 2G of data.

Contributor
Posts: 49

Re: sasv9_local.cgf settings for SAS VA Non Distributed

Thank you Alexal. Are there anything besides memsize? Anything related to autoload, etc... that we need to add into sasv9-local?

SAS Super FREQ
Posts: 558

Re: sasv9_local.cgf settings for SAS VA Non Distributed

@Matt,

 

Nope, but if you are using the autoload process to start the LASR server, do not forget to adjust MEMSIZE in AutoLoad_usermods.cfg. This is important.

Contributor
Posts: 49

Re: sasv9_local.cgf settings for SAS VA Non Distributed

Ok. Great. Thank you for your prompt response. 

Contributor
Posts: 49

Re: sasv9_local.cgf settings for SAS VA Non Distributed

Are there any recommendation for MEMSIZE? For now I set it to 1GB. I am sure it all depends on the volume of data but still if there is something recommended by SAS let me know.

SAS Super FREQ
Posts: 558

Re: sasv9_local.cgf settings for SAS VA Non Distributed

@Matt,

 

No, we do not have specific recommendations but 1GB is very low. By default MEMSIZE is 2GB. You need to be very careful with setting MEMSIZE, just do not forget that this option applies to all SAS sessions. So for an example, if you do "MEMSIZE 0", anyone who starts SAS session can consume all memory on the server.

Trusted Advisor
Posts: 1,852

Re: sasv9_local.cgf settings for SAS VA Non Distributed

Hello @Matt,

 

I strongly recommend you to read this article posted by @ErwanGranger : https://communities.sas.com/t5/SAS-Communities-Library/It-s-the-memsize/ta-p/239224

 

@alexal mentioned:

 

No, we do not have specific recommendations but 1GB is very low. By default MEMSIZE is 2GB. You need to be very careful with setting MEMSIZE, just do not forget that this option applies to all SAS sessions. So for an example, if you do "MEMSIZE 0", anyone who starts SAS session can consume all memory on the server.

 

On that note, I would like to comment that:

  • No users should actually do that, unless the use SASStudio. And for that purpose, perhaps another SASApp/Workspace server would be more interesting. 
  • I think that what @alexal wanted to say, indirectly is that "anyone who starts SAS session could consume all memory on the server"

The MEMSIZE system option limits the total amount of memory that is available to each SAS session. It places an enforced limit on the amount of virtual memory that SAS can dynamically allocate at execution. If MEMSIZE is set too low, your jobs can fail, and errors appear in the SAS log indicating that insufficient memory was available. By contrast, the REALMEMSIZE and MAXMEMQUERY system options, the SORTSIZE= option in the SORT procedure, and the SUMSIZE= option in the SUMMARY procedure all provide for procedure tuning.

 

You have been properly advised to set up MEMSIZE, SORTSIZE is another good one to take care carefully regarding performance. Depending on your data and queries, just a megabyte of difference can create a difference of several seconds or even minutes in your VA reports.

 

As @ErwanGranger mentioned, the general advise is just to do as below. If you need posterior fine tuning, you can always contact SAS Technical Support (or your SAS representative) or an specialised partner on SAS deployments:

 

……./config/Lev1/SASApp/WorkspaceServer/WorkspaceServer_usermods.sh
This file, in VA environments should contain:

USERMODS_OPTIONS="-memsize 0 -cpucount ACTUAL "

 

Contributor
Posts: 49

Re: sasv9_local.cgf settings for SAS VA Non Distributed

Posted in reply to JuanS_OCS

Thank you. Will surely review the note.

Ask a Question
Discussion stats
  • 8 replies
  • 176 views
  • 4 likes
  • 3 in conversation