Exploring, predicting and reporting with SAS Visual Analytics and SAS Visual Statistics

cannot test stored process & Pooled workspace server successfully in sas va 9.4!

Reply
Contributor
Posts: 68

cannot test stored process & Pooled workspace server successfully in sas va 9.4!

Hi All!

I'm new SAS VA 9.4-distributed, I had a problemb after I finished my installation.

My 'spooled workspace' and 'stored process server' error was not tested successfully...

I have installed, configed and logined as ordered h1.png, h2.png,h3.png as attached... and SPawner'log and console as attached.

Please help me to fix them.

Thanks.

Attachment
Attachment
Attachment
Trusted Advisor
Posts: 1,852

Re: cannot test stored process & Pooled workspace server successfully in sas va 9.4!

Hello @htin

 

Your logs are full with this message:

 

2017-11-09T12:53:45,854 ERROR [00466965] :sasadm@saspw - No host credentials exist to start this server. 
Either the client needs to send in host credentials, or credentials need to be specified for the server.

What maintenance of SAS are you deploying? Please give a look into this note, specifying that this is a known problem on M1 and solved in M2: http://support.sas.com/kb/57/521.html

 

Also, you can check if, from the node1 itself, you can at least telnet the ports for STP and PWKS.

 

 

 

 

Contributor
Posts: 68

Re: cannot test stored process & Pooled workspace server successfully in sas va 9.4!

Posted in reply to JuanS_OCS

Hi Juan!

Thanks so much for your answer!

 

I meant that I have installed sas va 9.4, but when i logined to client site to import data, test sas va's dashboard...., but I had a problem as attached..

So I thought that because of the 'cannot test stored process & Pooled workspace server successfully', so It caused error as attached..

sorry, i'm new sas va 9.4, please instruct to me step by step to fix them!

Thanks.

Attachment
Contributor
Posts: 68

Re: cannot test stored process & Pooled workspace server successfully in sas va 9.4!

Hi Juan!
When I ran: 'netstat | grep 8611', There is no anythings so that I couldn'n Check the Status of the Stored Process Server Ports.

So, Have I forgotten anythings...

Thanks.

SAS Super FREQ
Posts: 586

Re: cannot test stored process & Pooled workspace server successfully in sas va 9.4!

Are you trying to start the LASR servers with the sasadm@saspw account? Because that is an internal account and it cannot use a standard workspace server.

 

I also see the following errors. The test of these servers is failing because the server definitions are not being included. It looks like there is also problem with the launch credentials, sassrv.

 

  • The credentials specified for the SASApp - Pooled Workspace Server (xxxx) server definition failed to authenticate.  Therefore this server definition will not be included.
  • The credentials specified for the SASApp - Stored Process Server (xxxx) server definition failed to authenticate.  Therefore this server definition will not be included.

 

I would suggesting reviewing this topic:

 

http://go.documentation.sas.com/?cdcId=bicdc&cdcVersion=9.4&docsetId=bisecag&docsetTarget=p18wh3fg2j...

 

 

 

Contributor
Posts: 68

Re: cannot test stored process & Pooled workspace server successfully in sas va 9.4!

Posted in reply to Madelyn_SAS

Hi Madelyn!

'Are you trying to start the LASR servers with the sasadm@saspw account?' Yes.

And I Have fixed following http://go.documentation.sas.com/cdcId=bicdc&cdcVersion=9.4&docsetId=bisecag&docsetTarget=p18wh3fg2j....

and grant privilege 777 on folder  and 775 on file as promted windown... You can see my spawner logs and images with sassrv user and error.

In the end, There is still old error.

Please fix them to me!

Thanks.

Attachment
Trusted Advisor
Posts: 1,852

Re: cannot test stored process & Pooled workspace server successfully in sas va 9.4!

[ Edited ]

Hello @htin,

 

you should be able to validate Stored Process Server and Pooled Workspace server even with sasadm@saspw, unless you are on SAS 9.4 M1, as I referred above.

 

As a separate concern, why would you create a independent sassrv user? the sassrv should be registered under the General Servers group, and this group is the one that should be added  on your SAS Stored Process and SAS Pooled Workspace servers, as SAS Token Authenticator. Also, on General Servers, on the account tab, if you see no stars (*******) on the password field, it means it needs to be filled in for this specific account,  and DefaultAuth as Authentication Domain.

 

Once you ensure all is right, you would need to Restart your Object Spawner.

 

Anyway, I see you are a bit lost, I would highly recommend you to get the support from SAS Technical Support or a SAS Consultant or specialised partner, since I guess you would like it to work in 1 go, not after many tries which only adds time to the delivery of your environment.

Ask a Question
Discussion stats
  • 6 replies
  • 253 views
  • 2 likes
  • 3 in conversation