Exploring, predicting and reporting with SAS Visual Analytics and SAS Visual Statistics

Which VA Version for SASKit API

Reply
New Contributor
Posts: 2

Which VA Version for SASKit API

Hello :-), which Version of VA we need, to use the SASKit API for SAS iOS integration? 9.4 or lower, or is it possible to use Viya ? Thanks alot!
SAS Employee
Posts: 18

Re: Which VA Version for SASKit API

The VA versions supported are the same as the requirements documented as if you were downloading SAS Mobile BI from the App store which are VA versions 7.3, 7.4, 8.1, and 8.2) The biggest version requirement is the Xcode version.   The SDK was compiled using xcode version 9.2.   So if you are trying to run the SDK with the latest version of XCode version 9.3 then it is not going to work.   The GitHub readme file explains this: 

https://github.com/sassoftware/sas-sdk-for-iOS-examples/blob/master/README.md

 

"Because Swift does not yet have ABI compatibility, we are required to package the swift runtime with the built framework. This means that consumers of the framework must compile apps that use the framework with the same swift version as was used for compiling the framework. For release 8.22, the framework was built with Xcode 9.2 (9C40b)."

 

New Contributor
Posts: 2

Re: Which VA Version for SASKit API

Thanks alot,

 

the XCode Workspace with the Examples is already working, the next step is to connect to our VA Installation in Viya.

 

Best regards

Ask a Question
Discussion stats
  • 2 replies
  • 128 views
  • 1 like
  • 2 in conversation