Exploring, predicting and reporting with SAS Visual Analytics and SAS Visual Statistics

Unable to schedule the auto load audit data.

Reply
Contributor
Posts: 30

Unable to schedule the auto load audit data.

 

Hi,

 

For autoloading audit data I m running runsas.bat file in EVDMLA file but when i tried to run schedule.bat file I m geeting errors and in the log file. Please find the attached log file. 

 

Kind request is to explain the solution in detail.

 

Regards,

Karthik

Trusted Advisor
Posts: 1,191

Re: Unable to schedule the auto load audit data.

Hello @Karthikk,

 

we are missing the log file you said it is attached. In other hand, Please give as details of the steps/approach you followed to configure the autoload of the audit data, and please let us know some detauls of your deployment: SAS VA version and SAS maintenance, OS and version, VA distributed or non-distributed.


Thank you.

Juan

Contributor
Posts: 30

Re: Unable to schedule the auto load audit data.

Hi JuanS,

 

I am using SAS VA 7.3 Non distributed version on Windows platform.  I followed these steps to enable the audit report.

 

  1. Open the SAS Management Console and connect to your SAS Metadata server as an administrator

 i.Select the Plug-ins tab

ii.Select Application Management SAS Application Infrastructure Visual Analytics 7.3

iii.Right-Click on “Visual Analytics 7.3″ and choose Properties

iv.On the “Visual Analytics Properties” panel, Select the Advanced tab

v.On the Advanced tab, edit the “va.AuditingEnabled” property and change its value to “true”

vi.Then Click the “OK” button to save your change

  1. Restart the SAS Web application services.
  2. Start the LASR services
  3. Run the runsas.bat from below similar location with the same user through which you start the LASR server

<SASCONF>\Lev1\Applications\SASVisualAnalytics\VisualAnalyticsAdministrator\EVDMLA

  1. Post that you should login to VA Hub and go to LASR tab to see if the AUDIT_VISUALANALYTICS table is loaded or not.

 

These are the steps followed to enable audit report for which i am able to see the reports. 

 

But the issue is when i tried running schedule.bat file to schedule this for regular intervals i am find errors ehich are in log file. Sorry unable to attach the log file so please find the log details below.

 

Kindly let me know.

 

========================================================================================================

NOTE: Log file opened at Mon, 20 Mar 2017 10:45:27.023
1 The SAS System 10:45 Monday, March 20, 2017

NOTE: Copyright (c) 2002-2012 by SAS Institute Inc., Cary, NC, USA.
NOTE: SAS (r) Proprietary Software 9.4 (TS1M3)
Licensed to LIFESTYLE INTERNATIONAL PVT LTD, Site 11603803.
NOTE: This session is executing on the X64_SRV12 platform.

 

NOTE: Additional host information:

X64_SRV12 WIN 6.2.9200 Server

NOTE: SAS initialization used:
real time 22.14 seconds
cpu time 0.03 seconds

NOTE: Library TEST does not exist.
ERROR: CLI error trying to establish connection: [Oracle][ODBC][Ora]ORA-01005: null password given; logon denied
NOTE: Libref valib successfully assigned from logical server.
NOTE: Libref stpsamp successfully assigned from logical server.
NOTE: Libref LMG_MAX successfully assigned from logical server.
NOTE: Libref SASDATA successfully assigned from logical server.
WARNING: Libref test may not have assigned correctly from logical server.
ERROR: Libref DR_Ref failed to assign from logical server.
NOTE: Libref Local_E successfully assigned from logical server.
NOTE: Libref Local_F successfully assigned from logical server.

NOTE: AUTOEXEC processing beginning; file is C:\SAS\Config\Lev1\SASApp\appserver_autoexec.sas.


NOTE: AUTOEXEC processing completed.

1 /*
2 * AutoLoad
3 *
4 * Purpose: Synchronizes SAS data sets placed in a single disk location with
5 * a single LASR Analytic Server library defined in metadata.
6 *
7 */
8
9 /* Set the name of the LASR library to which to Auto Load */
10 %LET AL_META_LASRLIB=Environment Manager Data Mart LASR;
11
12 /* Include and execute main AutoLoad functionality */
13 %LET INCLUDELOC=D:\Program
13 ! Files\SASHome\SASVisualAnalyticsHighPerformanceConfiguration\7.3\config\Deployment\Code\AutoLoad/include;
14
15 /* ------- No edits necessary below this line -------- */
16 filename inclib "&INCLUDELOC.";
17 %include inclib ( AutoLoadMain.sas );
3832 %AutoLoadMain;
VA.AutoLoad.Location =C:\SAS\Config\Lev1\AppData\SASVisualAnalytics\VisualAnalyticsAdministrator\AutoLoad\EVDMLA

va.monitoringPath=C:\SAS\Config\Lev1\Applications\SASVisualAnalytics\VisualAnalyticsAdministrator\Monitoring
NOTE: DATA statement used (Total process time):
real time 0.11 seconds
cpu time 0.04 seconds

2 The SAS System 10:45 Monday, March 20, 2017


NOTE: The file
"C:\SAS\Config\Lev1\Applications\SASVisualAnalytics\VisualAnalyticsAdministrator\Monitoring\PIDs\autoload_EnvironmentManagerDa
taMartLASR.pid" is:

Filename=C:\SAS\Config\Lev1\Applications\SASVisualAnalytics\VisualAnalyticsAdministrator\Monitoring\PIDs\autoload_EnvironmentM
anagerDataMartLASR.pid,
RECFM=V,LRECL=32767,File Size (bytes)=0,
Last Modified=20 March 2017 10:46:46,
Create Time=20 March 2017 10:46:46

NOTE: 1 record was written to the file
"C:\SAS\Config\Lev1\Applications\SASVisualAnalytics\VisualAnalyticsAdministrator\Monitoring\PIDs\autoload_EnvironmentManagerDa
taMartLASR.pid".
The minimum record length was 4.
The maximum record length was 4.
NOTE: DATA statement used (Total process time):
real time 0.09 seconds
cpu time 0.01 seconds

NOTE: Libref DBLOG was successfully assigned as follows:
Engine: BASE
Physical Name: C:\SAS\Config\Lev1\AppData\SASVisualAnalytics\VisualAnalyticsAdministrator\AutoLoad\EVDMLA\Logs
NOTE: LASR Auto Load 7.2
ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.
NOTE: Task Name: AUTOLOAD
ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.
NOTE: Process ID: 3860
ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.
NOTE: Configuration Settings:
ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.
NOTE: METASERVER=lsiplprodsasva
ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.
NOTE: METAPORT=8561
ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.
NOTE: METAREPOSITORY="Foundation"
ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.
NOTE: METAUSER=
ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.
NOTE: METAPASS=XXXXXXXX
ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.
NOTE: LIBRARY=Environment Manager Data Mart LASR
ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.
ERROR: LASR Auto Load either cannot find Environment Manager Data Mart LASR library, or the library is not enabled for auto load.
ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.
ERROR: Check the following:
ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.
ERROR: 1- Ensure metadata server, port, and repository are set correctly
ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.
ERROR: 2- Ensure metadata user and metadata password are set correctly
ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.
ERROR: 3- Ensure library exists, has a unique name, and has VA.AutoLoad.Enabled extended attribute set to "Yes".
ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.

ERROR: Errors printed on pages 1,2.

NOTE: SAS Institute Inc., SAS Campus Drive, Cary, NC USA 27513-2414
3 The SAS System 10:45 Monday, March 20, 2017

NOTE: The SAS System used:
real time 1:35.09
cpu time 0.21 seconds

NOTE: Log file closing at Mon, 20 Mar 2017 10:46:47.283

 =============================================================================================

 

Regards,

Karthik

 

Trusted Advisor
Posts: 1,191

Re: Unable to schedule the auto load audit data.

[ Edited ]

Hello @Karthikk,

 

if you ever created an autoload library/folder, then you will probably know what is going wrong already. The difference for the EVMDM autoload, is that it will create an Autoload on your "private" LASR server, not in your Public LASR.

 

  • The user that schedules the autoload windows scheduled task, will require some authorizations:
    • On Windows: read, at least, permissions on the EVM autoload folder and the EVM scripts folder. And read/write permissions on both Logs folder.
    • On the SAS Metadata:
      • The user must be registered in the metadata.
      • The user must have enough permission (Data Admin and VA Admin groups on the metadata.
      • The user must be the same, or in the same group than the user that started the LASR server
      • The user , or its group, must have enough permissions on the SAS Metadata folders and resources (the data mart library and folder, the LASR server-read-, etc).

 

Contributor
Posts: 30

Re: Unable to schedule the auto load audit data.

Hi JuanS,

 

Thanks for the reply I understood The user part which u have mentioned i am using SASADMIN user which has all rights to it.

I am confused about the permissions. CVan u explain how I am supposed to check and how to change. 

 

And also now as you said for  Public LASR what am I supposed to do now I mean do i need to make any changes??

 

If you could kindly elobarate it and tell me that would be of a great help. Kindly understand i m not SAS ADMIN who performs these in regular basis.

 

Regards,

Karthik

Ask a Question
Discussion stats
  • 4 replies
  • 223 views
  • 0 likes
  • 2 in conversation