Exploring, modeling, predicting and reporting with SAS Visual Analytics and SAS Visual Statistics

Shared Data tables are not being loaded

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 10
Accepted Solution

Shared Data tables are not being loaded

I am running SAS Visual Analytics on a Linux server.

 

From SAS Visual Analytics Administrator, I started the "LASR Analytic Server" and the "Public LASR Analytic Server".

 

When I go to the LASR Tables view, I see that all the sample tables in "/Products/SAS Visual Analytics/Samples" are showing a green icon but all my tables that I had loaded a month back and had been working on since in "/Shared Data/SAS Visual Analytics/Public/LASR" are showing red.

 

If I select one of these tables and click on "Reload", I get a popup saying: "Not processed (not reloadable)"

 

If I view the "Last Action Log", it shows:

 

NOTE: Libref LASRLIB was successfully assigned as follows: 
      Engine:        SASIOLA 
      Physical Name: SAS LASR Analytic Server engine on local host, port 10031
NOTE: Libref LASRLIB was successfully assigned as follows: 
      Engine:        SASIOLA 
      Physical Name: SAS LASR Analytic Server engine on local host, port 10031
NOTE: The table LASRLIB.TABLE1 does not exist in the SAS LASR Analytic Server on host 'localhost', port 10031.
ERROR: File LASRLIB.TABLE1.DATA does not exist.

NOTE: The SAS System stopped processing this step because of errors

 

What could the problem be? These tables used to work fine.


Accepted Solutions
Solution
‎06-17-2016 08:42 AM
Frequent Contributor
Posts: 121

Re: Shared Data tables are not being loaded

It sounds like your source table has disappeared or at least disappeared from SAS VA's view.

 

You have several choices:

  • Reload from the source
  • Reload through the GUI (if setup correctly it will load by itself going forward)
  • Implement the AutoLoad process
  • Schedule through the Data Builder

Let me know which method works.

 


Tricia Aanderud
Zencos Consulting
Twitter: @taanderud - Follow me!

View solution in original post


All Replies
Solution
‎06-17-2016 08:42 AM
Frequent Contributor
Posts: 121

Re: Shared Data tables are not being loaded

It sounds like your source table has disappeared or at least disappeared from SAS VA's view.

 

You have several choices:

  • Reload from the source
  • Reload through the GUI (if setup correctly it will load by itself going forward)
  • Implement the AutoLoad process
  • Schedule through the Data Builder

Let me know which method works.

 


Tricia Aanderud
Zencos Consulting
Twitter: @taanderud - Follow me!

Occasional Contributor
Posts: 10

Re: Shared Data tables are not being loaded

I deleted all the data sources and reloaded using the GUI. Still don't know why/how they dissappeared by themselves.

 

What do you mean by:

  • Implement the AutoLoad process
  • Schedule through the Data Builder
Frequent Contributor
Posts: 121

Re: Shared Data tables are not being loaded

 

Here's a blog post I wrote about the AutoLoad Feature.  You will need admin rights to use this feature - but you can turn it on through the Metadata.  Then just place your dataset, spreadsheet, or text file in the indicated folder.  It will check the folder every 15 minutes for new or changed content.

 

The Data Builder has a scheduler that can extract data from a library and load it to the LASR server.  You can read more about that in the User Manual.


Tricia Aanderud
Zencos Consulting
Twitter: @taanderud - Follow me!

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 3 replies
  • 900 views
  • 0 likes
  • 2 in conversation