Exploring, predicting and reporting with SAS Visual Analytics and SAS Visual Statistics

SAS VA - New AutoLoad Instance Instructions

Reply
Occasional Contributor
Posts: 12

SAS VA - New AutoLoad Instance Instructions

Does anyone have a step by step guide that can help with the implementation of a new AutoLoad instance within SAS VA. I have tried SAS videos, Admin Guide, etc. but seem to be missing some steps and not quite clear on some things. Perhaps there is a better guide somewhere before I escalate to Tech Support? Thanks in advance!

SAS Super FREQ
Posts: 556

Re: SAS VA - New AutoLoad Instance Instructions

Posted in reply to egwilliamson

@egwilliamson,

 

Every step is described in the administration guide. What exactly is not working for you?

Occasional Contributor
Posts: 12

Re: SAS VA - New AutoLoad Instance Instructions

Attached is the new Autoload instance log file after following all setup instructions present within the Admin Guide.

SAS Super FREQ
Posts: 556

Re: SAS VA - New AutoLoad Instance Instructions

Posted in reply to egwilliamson

@egwilliamson,

 

It appears that your library is not associated with the LASR server. Please open SAS Management Console -> right-click on that library -> Properties -> Data Server. What is selected in "Database Server" & "Connection"?

Occasional Contributor
Posts: 12

Re: SAS VA - New AutoLoad Instance Instructions

Database Server: Public LASR Analytic Server - servername
Connection: Connection: Public LASR Analytic Server - servername

Should I be creating a new LASR Server?
SAS Super FREQ
Posts: 556

Re: SAS VA - New AutoLoad Instance Instructions

Posted in reply to egwilliamson

@egwilliamson,

Should I be creating a new LASR Server?

Nope.

 

In the same window, go to Options, what have you specified in Libref and Server Tag?

Occasional Contributor
Posts: 12

Re: SAS VA - New AutoLoad Instance Instructions

Libref: "CustomerName"LIB
Server Tag: left blank
SAS Super FREQ
Posts: 556

Re: SAS VA - New AutoLoad Instance Instructions

Posted in reply to egwilliamson

@egwilliamson,

 

First off, server tag shouldn't be empty. For the public LASR server, the tag will be VAPUBLIC.

 

In your log I see that you have specified the following AL_META_LASRLIB:

 

>> %LET AL_META_LASRLIB=DellAutoLoad;

 

and this error:

 

>> -4 matching libraries found.

 

The autoload process cannot find the library with the name "DellAutoLoad". Either, because that library doesn't exist or users don't have required access.

Occasional Contributor
Posts: 12

Re: SAS VA - New AutoLoad Instance Instructions

Thank you so much for your help! I have gone back through the LASR Server creation steps and fixed the errors from before. I forgot to enable some of the extended attributes and the folders generated within AppData for the new Autoload instance were under the wrong user permissions. Once those items were adjusted AutoLoad ran and completed successfully. Thank you again!
SAS Super FREQ
Posts: 556

Re: SAS VA - New AutoLoad Instance Instructions

Posted in reply to egwilliamson

@egwilliamson,

 

You are welcome!

Ask a Question
Discussion stats
  • 9 replies
  • 179 views
  • 0 likes
  • 2 in conversation